Data roaming not working on FP4 after update to Android 12

Hello after I upgraded to Android 12, I’ve been unable to use cellular data. I’m currently abroad, so I’m using data roaming, and after I updated to Android 12, I have been unable to use cellular data, only WiFi.

1 Like

Hi there! Are you abroad in France or Suisse? Then this could be the case:

No. I am in Germany. It was working here until I upgraded.

So you could try to reset the APN to default settings. Had to do this multiple times in the past, even with a “native” German SIM.

No, it didn’t help at all.

Hmmm, I would try if setting a specific mode will help, like only 3G, next 4G, 5G… But I don’t really have a clue what could cause this, so it’s just trial and error.
You probably already tried switching roaming off an on again?
Depending on the remaining length of your stay, you could test an eSIM, there are cheap ones to order only for just a couple of euros. You should look for one which has a German roaming partner different to your current provider though.
Or even wipe the cache partition, that’s the most you could do without any data loss.

Yeah, I tried that, I have plenty of cellular data included in my native plan, and I’m staying here for a while, so it’s a shame that my cellular data stopped working.

You probably thought about it, but just to be sure:
did you check whether the proper SIM is still selected for mobile data?

(It was one of several settings that was changed after upgrading to A9, in my case.)

What exactly do you mean? I only have one sim.

The phone is dual-SIM, right? Don’t know how it plays out when you use just one SIM and I don’t have an FP4, but I assume in the settings there’s something like “SIM cards”?

The phone allows for one physical SIM and a virtual one, I however only have the physical one.

Perhaps still worth checking the settings?
(Not SIM “cards” but SIM …)

1 Like

My wife had the same issue after updating her Fairphone 4 yesterday. The suggestions above didn’t work (tried most) but after changing the mobile data network back and forth, suddenly she is back online.

Wait, false alarm, wifi was on…

Check the roaming settings (ipv4/ipv6) in the APN and see if you can change and if this helps.

1 Like

It says that APN is not available for this user.

What do you mean exactly? Maybe enter your new APN then?

What is the original provider you bought your SIM from?

1 Like


I also have this problem after updating to Android 12.
I’m located in Norway. Worked fine before.

I have Telia, however the SIM-card is from Chess whom Telia later purchased.

It doesn’t save the settings, if I try to enter APN manually.

Do you have the option “Reset to default” in the three dot menu top right, and have you tried that? :thinking:

1 Like