Data connection file size limit


So I just got my phone, took a bit of work to get the connection working, turns out just a problem with the apn settings.

Anyways, I got that fixed, and proceeded to install the google app package. This turns up: “The file you’re trying to download is too large for mobile connections (~100MB). Please enable Wi-Fi connection and try again.”

I don’t have Wi-Fi at home and the connection I have in the phone is my only connection to the internet. It’s a data connection with unlimited usage for a monthly fee and definitely enough speed to download large files, so this seems kind of stupid. Is there a way around this or do I really have to go searching around for public Wi-Fi connections to download large files on the phone? I could do that, but it kind of defeats the point and it would be a bit of a disappointment if the first thing I try to do with the phone ends up not working just because of some arbitrary limit that can’t be turned off.


A better way of dealing with this would be to show a warning, but to let the user proceed if he or she wants so. Same thing applies for the Fairphone software updates: The official updater application also refuses to download an update through something else than Wi-Fi if I’m not mistaken.

Hi @Marko,

I think you could download the file and install it manually in recovery mode (I guess you’d have to do the same for any updates…). It really is a hassle, I was surprised by this constraint, too. And I’m not aware of a way to disable it.

Anyway, I found two topics regarding this in the Support section.
I found this first. BUT the file you should download here is for FP1. You seem to own a FP1U, so I’m not sure if this actually works.
Therefore I’d go with this second solution I found. Scroll all the way down to the last answer. There’s a link to where you can download the google apps package manually and then a link to instructions on how you’d install them in recovery mode.

Hi @Marko

Perhaps your mobile data limit is enabled, and is this causing the problem.

Go to Settings > Press “Data Usage” (the word, not the slider). You get two panels: “Overview” and a panel with your provider name. Press the latter (provider name). Make sure “Mobile Data” is on and disable “Set mobile data limit”. Not sure if this is the right solution, but checking to make sure is never a bad idea :wink:

Kind regards