Data connection failure on EE UK after FP3 Update 901.4.A.0019.1

It did for me. No data downloads possible at all but sending whatsapp and fb messenger messages seemed to work fine.

1 Like

Sadly there is no convenient or slightly inconvenient way of downgrading the OS

You may like to open a support ticket with Fairphone officially and draw their attention to this topic.

1 Like

Thank you all for sharing your experience. If you are affected by this issue and haven’t already done this, submit a ticket. This helps us with prioritizing and you’ll be personally notified if there are progress updates.


Also got this exact same problem. Fairphone 3+, UK EE, software update, no longer downloading data from my mobile network. Tried a slew of troubleshooting fixes, including but not limited to a factory reset and backup restore, which messed up a number of other unrelated things. So, good to know all that was pointless.

1 Like

Thank you for the link to raise a ticket @Yasen_Tomov, I too am having an issue with data connection after the last security patch update from last week.

I’ll follow up with FP support.


I have the same problem after every update since Android 11. The workaround is setting Network type to 2G, reboot and after that reset to 4G/3G/2G.


Sadly that is not ‘the’ workaround although it may work for you and some others, but thanks for the update.

Where I reside I don’t have good network signal and use Wi-Fi so I am not bothered but had reason to go to the local village and try out your idea.

Before I left my setting was Auto (4G, 3G, 2G) When I tried to change it the only options I had and still have after reboots and walking around are LTE or 3G. So I have no auto and no 2G ??? Maybe it’s just a network signal anomaly in this area.

Switching between them has no effect on data availability.

Thanks and all the best

Just to note an anomaly.

I was about to leave home, where I have no signal and disabled Wi-Fi and enabled network and data. As I walked away I picked up a signal and data connection. Checked one of my websites for updates and all was fine.

Once I’d lost the network connection the data did not come back up whilst I walked through 4G, LTE+, LTE, 3G and E

I thought for a minute that EE and Fairphone had sorted it :frowning:

Hi everyone, I’m having the same issue with EE in the UK, tech support from EE don’t seem to have a clue, I’ve tried everything mentioned above /on forums from resetting APN to full factory reset, the sim status shows it’s getting a signal, but that the mobile internet is disconnected, really frustrating, been three days now without mobile data, which I really need!

Updated android and now cannot use mobile internet - it happened with last update but that resolved by resetting APN. This time I’ve tried APN reset, reboot, factoru reset nothing works. It says it’s connected but only gprs?? Really frustrating - feels like phone is ruined! Any ideas would be appreciated, I’ve sent a ticket but they take ages to reply

3 posts were merged into an existing topic: Software update: 8901.4.A.0019.1-gms-edfd6a4e

No fresh updates on my end I’m afraid. Last contact regarding my ticket on the 28th, just to say it was being looked into. Fairphone ticket raised 17th December. Good luck searching for the solution!

There’s no point in looking for a solution as a fix is already in the pipeline awaiting Google certification. ETA unknown.


I fixed this issue by setting up a new APN with ipv4 & ipv6 enabled. The default only has ipv4. All the other settings are the same as the default ‘everywhere’ APN, the password is ‘secure’. Perhaps EE are running low on IPv4 addressees.


Welcome to the forum.

I noticed this difference between my two FP3s so thanks for confirming. Let’s hope this will work for others too.

All the best

Have you tried enabling IPv6 in your APN? Fixed it for me.

1 Like

What @ostergaard is referring to is.

Settings > Network and Internet > Mobile network > Advanced > Access point names >

then for both Internet and MMS

APN protocol and ( APN roaming protocol if you want to use roaming)



Ah I tried this and didn’t work for me, really annoying! Thanks everyone let’s hope the patch to fix it comes out ASAP :+1:

1 Like

Just to be sure, you may well have to reboot the phone before it takes effect.

I don’t have to reboot, and can reliably disable and enable my data simply by editing the APN I added. My phone is not rooted, which I assume is why I cannot edit the default APN so had to add a new one.