Cyanogenmod 11 for Fairphone FP1(U) Install guide + experiences

and given that any android < 4.4 is now known to have a major security hole, and the official version is still stuck at 4.2, this has jumped from nice-to-have to the top of my wishlist. I’ll be trying this out as soon as i have a few hours.

1 Like

I have IE deactivated here, so there is only Firefox… :wink: Also not using any adblockers…
I tried the download today and everything worked. Probably there was just too much traffic last night… :slight_smile: Thanks for responding, anyways! :thumbsup:

UPDATE CM FP 0.1 -> CM FP 0.2 (CM 11 M10)

  1. Download 0.2 zip file and put on SD Card
  2. Go to Settings -> Developper options -> tick Advanced Restartmenu (if not already performed when using the step by step guide above)
  3. Power -> Restart -> Restart in Recovery mode (here use upper and lower volume key to navigate und Power button to select / Enter)
    -> Install zip
    –> choose zip from /storage/sdcard 1
    ->Reboot System now (may take quite a while)

This update should provide dual sim support according to the official CM resources. Please give some feedback, I’ll see if I can try it out myself…
For newest version and feedback see the xda thread. Please support and thank Developer chrmhoffmann


Warning: Shellshock seems to be an issue with CM11 on Fairphone.

Does CM have a built-in shell that is used by other applications (and is the terminal app just a front-end to that) or is the terminal app self-contained? I have no idea myself, haven’t looked into CM that closely, but that makes all the difference for whether shellshock is a problem here.

It seems to be affecting all non-busybox releases of CM. They are working on a fix right now:
No idea, when this one will make it into CM for FP…

Ok short update here: Current release (M10) seems to run pretty unstable. I’m having 1-2 crashes / day. But this doesn’t seem to be a Fairphone issue as many users from different models are reporting problems with M10.
Combined with the still unaddressed issue of the shellshock bug, it’d be probably better to wait for the M11 to fix these issues.

1 Like

I have installed it yesterday and noticed two things.

No notification lights blinking anymore.

And where the original FP software has the opportunity to start the phone up with the alarm clock in CM this doesn’t work. For me a big down point as I want to have my phone turned of in the night.

For the rest it seems to work quite good for me so fa (although makes it much harder to support with software issues on the regular FP software, so I might need to switch back soon :wink: )

Any chance we’ll see a cynogenmod version for FP with these features in the (near) future:

  • fairphone branding (I really love the startup sequence)
  • automatic scheduled turning on/off of the phone as in the FP firmware
  • a camera capable of recording these 3D-panoramas (MPO-files)
  • notification lights working
  • shellshock fix
  • update/install via the fairphone updater app alongside the other 2 OS (stock and FP OS)




I installed it yesterday. I just can only urge everybody who want’s to install it to check twice, whether you got the right cwm installed.
The only bug I discovered, that is not listed, is that the clock app doesn’t work. But it seems like I am the only one with that problem. So is there any advice?

Other than that I am very pleased. A few crashes now and then, but nothing that’s to different from fp os.

Something I also noticed, but that might just be me.
When I connect the FP to my PC I don’t get the options anymore to use it with MTP or as USB mass storage.

Anyone else have this issue?

Hi everybody!!
i’m new in the forum.

i’ve just followed the tutorial to install CM on the fairphone.
well it works great! :smile: unless i don’t have a windows PC to strictly follow the tutorial i managed to install CM on the phone. and it’s working…definitely great! tnx chris!! :smile:

the only problem i have is that the phone now is not able to see the phone storage…those 14 GB useful to install apps and stuff like that aren’t seen at all! so i have only 1 GB (really 0.89 GB) of free space.

could someone help?


You need to go to settings --> storage --> hit menu. There you can activate mtp.

1 Like

Cheers @SirLukeSchande that indeed works. Since I had my FP in January I hadn’t checked updates from CM on my old phones so wasn’t aware they moved it around.
It was the only place I actually didn’t look for it :wink:

Ohh how unfortunate. You might have two options:
1: Install the 1.6 OS Version with unified partition update.
2: Boot into recovery mode and perform a wipe data / factory reset.

I’m not sure if they work out alright. You might get some better help in the xda forum.

Again: Any bugs and feedback is best shared with the develloper in the xda thread (link see above) as Chris isnmost likely not active in this forum.

Hi @madde thanks for the quick response!!
I’ve posted a reply also on XDA. Thanks again :smile:

Anyway…I’ve managed resolving the partition problem. Now i got one big partition (the problem was with a previous disk encryption).

another problem i noticed: the phone won’t shut down!
long press on power button, tapping “power off” on the menu, the phone is shutting down everything but instead of a shut down i have a reboot.


I have the same problem as you had. I reflashed the Fairphone OS and installed the unified partition update, and then reinstalled the Cyanogenmod rom - but I still only see less than 1gb in intenal storage, along with my external sdcard which is recognised correctly.

I’ve had plenty of bugs to be honest - it’s not a stable system yet, but I’m killing off problems one by one.

I’d love to know how you managed to get one clean partition (although I have never encryted this phone, so it mightn’t be relevant to my situation…).


actually I copied the original FP img file on the sd card, wiped all data (I assume you could have CWM installed) and installed the FP 1.6 update. when you reboot the device flash the recovery image (the phone will ask you by default once the new OS is installed).
reboot the phone and start the FP OS, reboot it again in recovery mode to wipe again the data/cache… and all the wipeable :slight_smile:
install the partition update and then restart. restart the phone again and start with the cyanogen installation process.
more or less this is what I did to solve the previous problem… hope it’ll work also for you :slight_smile:

Anyone else noticing a shorter battery life with CM?

Might also be that I use a different Launcher and Locker, but still much shorter it seems.

I think I have noticed this too after updating to M10, but it might as well have to do with the display brightness settings.