Cyanogenmod 11 for Fairphone FP1(U) Install guide + experiences

Maybe FP can give chrmhoffmann a FP1U for testing/developing?

9 Likes

Maybe someone could provide a ZIP directly to be flashed and have the process as easy for other users to try out this fantastic step forward?
Anyways, thanks a lot for making this progress!

Flashing the ZIP file (See above) is actually the smallest issue. The hustle is, that you have to get the custom recovery.img in place for the ZIP file to work.
But all in all it won’t take longer then ~30 Minutes to set up cyanogenmod, which i think is absolutely alright.

I’ve just installed Cyanogenmod 11 and I have to say, it’s not actually as full of bugs as chrmhoffmann suggests. In fact, I actually get more reliable phone signal!

For those that are tempted to try and install, note that some technical know-how is required for the configuration of bootloader etc is required but the overall difficulty isn’t too high. It took be about an hour to install as I had some issues accessing the bootloader at first and the backups can take a while.

Very interesting development, I will try it out after the weekend! :thumbsup:

I installed the cm11 too. Installing went well with the tutorial. No strange things so far. I had dome difficulties with installing the mtk tools (never used it before), but once that was solved, everything went smooth. The phone feels snappier indeed. Nice development !! Thanks!

2 Likes

@jerry - yeah someone has put the launcher up on google :smile:

https://play.google.com/store/apps/details?id=de.lulebe.fairphone.launcher

2 Likes

The same build can be used for both FP1 and FP1U. I have tried

3 Likes

WOW - I will definitely watch this as usually the first thing I do when I get a phone is to install Cyanogenmod. One of the reasons I bought the Fairphone actually was because they stated they’d support alternate OS/Android versions… :wink:

For now I hope Dual SIM will get stable as it is something I rely on (one card for calls/texts, one for data) - but as soon as that works, I’m flashing…

Hey @madde

How did you experience the download of the zip-file? I clicked the download link from http://forum.xda-developers.com/fairphone/orig-development/rom-cyanogenmod-11-4-4-4-kitkat-t2862874 but it never started the download, just kept loading the site… Did you or someone else have the same issues?

There is a New download for the 0.2 Version. Did you try this one? Works for me, just takes a while to load…

Yes, I went to https://goo.im/devs/chrmhoffmann/cm-11.0/fp1/cm-11_FP1-ota-UNOFFICIAL-FULLOFBUGS-0.2.zip/ . Now it stops loading, but nothing else happens. The download does not start. The 0.2 Version does not seem to be available. Link seems to be broken. If I go to the upper folder (fp1), I have only the options to download 0.1 Versions…

Just tried it here and it works for me. Try accessing it with another browser or turn your adblocker off.

Cheers

1 Like

and given that any android < 4.4 is now known to have a major security hole, and the official version is still stuck at 4.2, this has jumped from nice-to-have to the top of my wishlist. I’ll be trying this out as soon as i have a few hours.

1 Like

I have IE deactivated here, so there is only Firefox… :wink: Also not using any adblockers…
I tried the download today and everything worked. Probably there was just too much traffic last night… :slight_smile: Thanks for responding, anyways! :thumbsup:

UPDATE CM FP 0.1 -> CM FP 0.2 (CM 11 M10)

  1. Download 0.2 zip file and put on SD Card
  2. Go to Settings -> Developper options -> tick Advanced Restartmenu (if not already performed when using the step by step guide above)
  3. Power -> Restart -> Restart in Recovery mode (here use upper and lower volume key to navigate und Power button to select / Enter)
    -> Install zip
    –> choose zip from /storage/sdcard 1
    —>cm-11_FP1-ota-UNOFFICIAL-FULLOFBUGS-0.2.zip
    ->Reboot System now (may take quite a while)

This update should provide dual sim support according to the official CM resources. Please give some feedback, I’ll see if I can try it out myself…
For newest version and feedback see the xda thread. Please support and thank Developer chrmhoffmann

4 Likes

Warning: Shellshock seems to be an issue with CM11 on Fairphone.

Does CM have a built-in shell that is used by other applications (and is the terminal app just a front-end to that) or is the terminal app self-contained? I have no idea myself, haven’t looked into CM that closely, but that makes all the difference for whether shellshock is a problem here.

It seems to be affecting all non-busybox releases of CM. They are working on a fix right now: http://review.cyanogenmod.org/#/c/73936/
No idea, when this one will make it into CM for FP…

Ok short update here: Current release (M10) seems to run pretty unstable. I’m having 1-2 crashes / day. But this doesn’t seem to be a Fairphone issue as many users from different models are reporting problems with M10.
Combined with the still unaddressed issue of the shellshock bug, it’d be probably better to wait for the M11 to fix these issues.

1 Like