Crashes every few minutes after reboot

I have no idea what is going on, but my FP2 keeps on freezing every few minutes after rebooting. It will then tell me that the app that was last on isnt responding, or (if no app was on) it will say “Fairphone Launcher 3 isnt responding”. It will only respond to the Reboot/Shutdown options that come after holding the power button for a few seconds. I decided it is time I update manually to the latest package, since the updater has never ever worked on my phone since I got it. But it doesnt stay “unfrozen” long enough to download the latest update, bluetooth-send it from my computer or download it from my dropbox account. It is one big mess :(. Please help, awesome Fairphoners :slight_smile:

If you have a microSD-card and a way of using it directly with your computer, try method 2 of the 4 methods listed in the manual install support article. If you don’t have a microSD card, you could try method 3, but this requires setting up software and drivers on the computer which can be a bit of a hassle.
These methods don’t rely on the phone booting all the way into a full system, so it should be more stable. If the phone still crashes in recovery mode, contact Fairphone support as there may be a hardware defect.

Hi Olave, did ýou manage to update your phone as suggested by Johannes, and did it solve the issue?

I am having the exact same problem since yesterday, after that the battery was totally empty (led flashing red when I started charging the phone).

I already had the latest OS version installed though (1.8.1)…and I’ve kept rebooting the phone over and over again, but it still crashes a desribed by Olave:

I deinstalled a couple apps which I though may cause the crash because of their autorun, and I managed to download another launcher between two crashes, but none of these solved the problem…

Any ideas? Please! (except a factory reset…since I haven’t backed-up the phone)

Hi everyone,
I am sorry this post won’t help any of you to fix the “Fairphone Launcher 3 isn’t responding”, but it confirms that this issue is not isolated : I do have exactly the same problem since 5 days. As a matter of fact, I cannot use anymore my fairephone 2…
Just like Olave_Nduwanje I Rebooted /Shuted down many times ; just like LeRenard I removed almost all my applications ; and also I charged my battery from 0 to 100%(I even uses different charging cables) but at the end it does not make any difference.
To all expert fairephoners, I am also calling for help!
Thank you!

Hey everyone, so this is what happened:

After a whole day of freezing, rebooting, downloading of the new update, I ended up being able to download the update and reinstall the update. That seemed to have fixed the problem. Everything was working just fine, arguably better than ever before.

About two days later, all of a sudden, it started doing the same thing. At some point, I noticed that the Play Store was updating a bunch of apps. I figured that might be causing the freezing. So, after another whole day of freezing, rebooting, Play store updating, then freezing, rebooting, etc. (and it really took a whole active day, cause it was freezing every few minutes and I had to reboot so as to continue the updates of the apps). Anyways, after that whole ordeal, it started working smoothly again, and it has not refrozen again.

Hope this helps.

My FP2 just crashed and rebooted. When booting, it starts to “optimizing apps” which takes like forever. When finally up and running, most apps don’t work or won’t start at all. After a minute or so the phone freezes. Then I get the message “Fairphone Launcher 3 does not respond”.

This has happened once before and the only thing I could do was a hard reset.

I must say I am extremely dissapointed of this phone. But unfortunately, there is no alternative.

Hi, this is a community forum. If you wish to talk to Fairphone staff about this, please check out the webpage.


This morning, my FP2 restarted and did all the app optimisation. Since then, I can’t use it more than a couple of minutes in a row.
I think it is because all the apps crash one after the other, including the launcher.
I have a few “bla bla app is not responding. Do you want to close it?”, sometimes with my launcher (either Nova or Fairphone one, and then everything freezes.

I have tried some things, like removing sim and SD cards, etc… But nothing changed.

I used to have freezes, but this time it is insane. Has it happened to someone else?

I’ve grouped a couple of topics that described similar symptoms and occurred around the same time. There may or may not be a common cause, but until that’s clear it’s going to avoid a lot of cross posting by keeping the discussion in a central place. Apologies for any confusion this may (have) cause(d).

1 Like

I’m not sure I suffer from the same basic problem, but my experience is at least similar to what has been reported so far:
The phone crashed while connected to AC adapter last week. When I noticed (a day later), the battery was drained (red LED blinking). Tried to boot, both with and without AC connected. In both cases, the phone shows the FAIRPHONE start screen, then sometimes goes on to show “Optimizing App n of N”, before booting again. When connected to the AC supply, I cannot turn it of, i.e., it always (tries to) boot(s) when connected to the AC.
Once, I left it in this cycle for really long, and behold, it did start eventually and showed 100% battery. Strangely, it didn’t recognize the AC anymore and started discharging very quickly, before crashing again and entering the aforementioned cycle again, in which it persists now.
OS version, as far as I can remember, is 1.8.1

Quick update on my side:

  • absolutely no improvement over the past 10 days. I didn’t want to do a hard reset right away as I still had some stuffs not backed up, so I just kept using the phone only a couple minutes per day…
  • in the meantime I sent a request to the support but I haven’t gotten any answer yet and I am not even sure it worked (no confirmation e-mail or anything else)
  • Yesterday I followed the instructions from the article: how-to-back-up-your-fairphone-2 before doing the hard reset
  • The fact that my computer couldn’t connect to the phone didn’t help. I bought a micro SD card and copied my “private files” on it using Amaze - which also took forever since I still had to reboot the phone every two minutes
  • I finally did the hard reset today after everything was backed up
  • when the phone restarted, I was NOT offered the opportunity to restore all my data as I expected - the step “Get your apps and data” from the google setup wizard simply didn’t show up!!!

I am SO pissed off about this whole thing and all the time I have lost beacause of it already. And now I have to reinstall all my apps and settings manually…

I love the Fairphone concept, but I am really on the verge of giving it up and buying another phone (like many users I have also experienced pretty much all of the known issues listed on the forum).

Yes, that is exactly the problem that I had. Like eralaek a hard reset (restore factory settings) seems to have solved the issue. But I’ve lost all my apps and settings in the process (despite having backed up everyting)

I had the same problem (FP2 freeze always after 2/3 minutes for each reboot).
But before to make the hard reset of the handset I needed to have backup of my data. I solved the problem uninstalling all of the apps that I installed at the beginning (except the ones that I should backup). After that the phone didn’t freeze anymore and I could do the backup.

I hope this case could help someone else… and obviously I am pissed off like all of you!!!

1 Like

My FP2 got exactly the same situation 2 days ago. I tried many things but there were not many choices to do since it works only few minutes before it freeze after each reboot.
I was advised by Fairhpone supporter to return to factory settings.

I tried to clean the Cache by CCleaner Apps as the last try.
Surprise! it worked out, it was not stable though it did not freeze for ca. 10 mins.
Facebook and FB Messenger Apps did not work so that I reinstalled them and now it works more than 2hs just like 3 days ago.
I’m hoping this will last for the next 5 years.

That is a good approach for solving such issue, well done and thanks for sharing your experience!
I believe you are a monster brain keeping quite a lot of intelligence in it.
As you have done the most rational thing possible at last and thus solved the problem.
Many other users as I can read here on the forum tend to keep it most simple:

  • don´t use a working backup solution, let alone having a separate sd card installed for this and complaint if things get lost
  • don´t uninstall third-party apps for whatever reason
  • don´t clean caches or settings if not successful
  • for heavens sake don´t factory-reset the device (to assure the issue won´t be solved thereby)

These users rather keep on the complaints that the device is not working properly and after all it´s Fairphones fault and the device is crap.

Actually it is indeed not the fault of the manufacturer. Everyone was free to buy this product or maybe a Samsung S7 instead.

So if not taking any (available) chance to solve an issue self, stop the complaint as it surely won´t help anyone, it is unfair and not very rational but annoying at some point.
If people think other phones operate all fine why did they even switch and buy a more expensive Fairphone as they could have buy instead of simply selecting another well known type.
My phone only showed very few of the listed issues and they were all solved meanwhile by updates.
Nevertheless I do not run all widely spread apps people think are a must-have like facebook, whatsapp and all this mainstream crap.
Anyway it looks like many FP2 users out there have them functioning fine though. I always read and consider the listed permissions of each app.
People can send their phones back to get them fixed or use their clear mind and try everything possible to prevent having to give it away for weeks and most surely have a clean phone after return. No manufacturer takes over guarantee for personal stored data.

Obviously there must be a remarkable amount of working phones out there as only very few report their struggles here.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.