Contacts take ages to load

For some time now (bug appeared about two months ago) my fairphone has issues in displaying contacts. This takes differnt forms:

  • incoming call: only the number shows (no contact name)
  • when making a call: shows loading icon for 20 sec up to a minute before any contact appears.

My specs:

  • I mostly store contacts on my Google account
  • Android version 4.2.2
  • Fairphone first edition
  • phone storage is not split anymore in two drives

Two things come to mind:

1.) You can try to clear the contacts cache and data. (System Settings > Apps > All > Contacts / Contacts Storage > “Clear Cache” / “Clear Data”)

2.) Around the time the problems first appeared did you:

  • install a new app?
  • start using a new app?
  • upgrade the os?
  • do the unified storage upgrade?
  • add a new Account that has access to contacts?

Don’t I risk to delete contacts by choosing “Clear Data”?

install a new app?
start using a new app?

yes… Boldbeast Recorder, Adobe Reader, Google Calendar

upgrade the os?
do the unified storage upgrade?

That was a couple of months earlier

add a new Account that has access to contacts?
that was months earlier the issue appeared (FB Messenger)

Sorry yeah first try only clearing the cache (also of Google Contacts or whatever it’s called [I don’t use Google] and FB Messenger) and if it doesn’t work do a backup first and then try clearing data.

Hi, I have the exact same problem, plus some more.
FP first edition, OS updated to the latest one.
My phone seems to fail when trying to type the name of a contact in text messages. The display of possible contacts does not show any name at all. Not a first world problem, but a nuisance nonetheless.
And, contacts load very slowly.
I installed Contacts Optimizer a month ago, but this issue only popped up a week or so ago,
any ideas how to solve this?


did anyone of you get this problem solved.
Because I have the exact same problem as well. FP1 second edition with the latest OS update.
It first appeared when I ran the last OS update. The contacts take really very long to load. Sometimes they do not even load at all and I have to restart the phone. Then other times the contacts load after quite a while, but when I click to a contact it opens but is completely empty. Also when I get calls or message it often doesn’t show the names but just the numbers even though I have the callers in my contacts.
I would be grateful for any solution, because I’m sick of restartin my FP about 3-5 times a day.


I’ve not had the problem, but I’ve two guesses how to solve the issue:

  1. If you synchronize your contacts, delete the (Google) account and add it anew.
  2. Sometimes system files get corrupted during an update and in this case it’s worth it to run an update again.

For completion’s sake: The last consequence would be to do a hard reset.

Hey Stefan,

thanks for the quick response and the useful tipps.
I will try them and hope they work.



1 Like

Hey there,

did you already check the size of your contact app? Mine was 80mb - much too big for the phone to handle (normal size is about 3-7mb I was told).

Hence I did a backup of my contacts and cleared all the data of the contact app. Afterwards I reinstalled the backup and my contacts app (now 5mb) was running smooth again. That did the trick for me.



Well done!
To exactly which size to you refer? Maybe you can post a screenshot where you checked this?
(I have similar problems with the message app)

To be found under Settings -> Apps -> all -> Contact Storage. Hope it helps!

Rematk: I found the solution in another forum, it seems to be a general issue with Android.

1 Like

Well, I’ve done everything: removed contacts, run an update again, reinstalled the phone, but nothing works… Oké, reinstalling worked for a couple of weeks, but now the problem is there again :-(. Fairphone, help!

Hello everybody :slight_smile:
I’ve been having the same problem.
Did anybody find a real solution yet?

Thankyou and all the best,

A post was split to a new topic: Contacts take ages to load (Fairphone 2)

And several weeks later, suddenly it worked again. Strange, but I’m glad with it :slight_smile: