Contacs not tied to any sim only want to call on one sim card

All of a sudden all my contacts (including in the phone and SMS app) tell me that the "x"sim card is switche off, do I want to switch it on? I don’t, because the calls I am trying to make are ones on the active (local at the moment) sim. The contacts have not been allocated to any sim card, and this problem has never happened before, it used to just connect. Now if I accept to switch on the passive sim card and then try to make the call, I am told that this sim is on roaming, and would I prefer to make the call on the local sim (the one that was switched on to start with). If I say yes, it connects. I don’t want both sims on because that drains the battery faster, so how can I get back to normal? I have tried rebooting, re-synchornising my contacts from the PC, nothing seems to work. Help, please.

Some questions (I see nobody could help you so far):

  1. Did you try to switch SIM slots?
  2. How old is your SIM card? The older the SIM card, the more likely it is to be defunct (a SIM card younger than 2 years should be ok, though).
  3. You could borrow a friend’s SIM card from the same provider and try it with that one. Does it work with that one?

This sounds more like a settings problem than a SIM problem. I would think the age of the SIM is irrelevant, since it worked for @Catherine before.

Re-syncing contacts should also not help, since the setting is AFAIK not saved with the plain contact, but possibly in the Contacts app.

Catherine, since there is a roaming warning, you could see if you find some suggestions to get rid of those on the forum. I remember that some people (specifically some from Telia/Sweden) had roaming warning problems due to settings considering the provider access points.

Don’t be shy to ask for more help here; sombody surely will walk you through some settings you can check.) It might be helpful to know which provider you are using, what apps you recently installed, and probably even if you crossed borders recently (regarding the APN settings and the roaming warning).

1 Like

Thanks for your message.
Well, both my sim cards are quite old, but clearly both are working - if both are switched on, I even get warned not to use the one that is on roaming (that is a Swiss one and when I was in Switzerland a couple of weeks ago that worked normally) and then the UK one does work, it just doesn’t work straight from the apps (contact, phone, sms) whether or not the other sim is on or not. Both work normlly for receiving calls or text messages.

Many thanks for your message. I don’t mind the warning about the sim on roaming, on the contrary, I think it is great, what I do mind is that I can’t make calls or send texts when I only have my UK sim on, which works perfectly on receiving calls and on making them once I go through the switching on of the Swiss sim and the warning, but not when it is the only one that is switched on. Even if the UK one is switchen off, I get the warning about roaming. I agree that it seems soem sort of setting problem

Did you try any of the solutions I suggested? I got that your SIM cards are working (more or less), but it wouldn’t do any harm to try another SIM card, would it? Also, if it is the same with the other SIM card, we could be more sure that it is a settings problem, like @humorkritik suggested.

Is it possible you accidentally choose the wrong sim as default. I tried to reproduce that and got the following result.

i opened the Phone app and then (the order is important) swiped in from the top (Quick Settings), there is a selection only visible in Phone and SMS allowing you to set a standard sim, use internet calls or always ask. The i selected “congstar” my second sim. This is indicated by a tiny purple line:

Then i opened settings -> Sim Management and turned the congstar sim off:

No back in the phone app, i tap a contact and try to dial, i get the following message: “congstar is now turned off. Would you like …”. This is probably the message you are talking of. I choose cancel.

Instead i swiped in from top and selected “simquadrat”. This is the active SIM. Now caliing works as expected.


Ah, I see: SIMs from two operators in two different countries. And you crossed borders in the past.

Well, first have a look at @ben’s message. If that doesn’t lead you somewhere, you could also dig into the APN settings and find out if everything is as it should be. (This will involve some web search for the correct APN settings for your providers.) I might be wrong, but I have the ideas that APN settings sometimes get messed up when crossing borders (that is: automatically changing network due to roaming, and then returning to your home network).

Just btw, I did not want to suggest to turn the roaming warning off, I rather wanted to know if you probably had a problem like those on Swedish Telia. From what I remember without quickly searching the forum, they got this message without being abroad, because of some Telia settings.

Actually it was due to virtual network operators where two operators shared the same network ID. But this was solved in a previous FP update (1.3 IIRC).
Another Telia Sweden issue on the forum was that new APN settings caused mobile data disruption. But this is of course irrelevant here.

1 Like

Many thanks to everyone who replied to my query, The problem is now solved, but just why I don’t understand,.
I switched off my UK sim card, then switched off the phone, waited a bit and then switched it on again, switched on the UK sim - and it worked, even after I switched off the Swiss one. It looks as if someone had set the phone to exclusively use the Swiss sim while I was there. But then why did it work all of a sudden after the switch off without my changing the settings? A mystery, but if it happens again, I may now know what to do.
Many thanks again to everyone who responded



I set this topic on autoclose. If it happens again, you will have enough time, to post again.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.