Connecting with pc


i also got the same problem. if i connect my fairphone to the pc it is not showing up. on the phone itself i only get the option to choose from various ways to connect to the pc but its not working. i also activated the debugging. normally i should get a pop up on the smartphone with this huge android picture (that green alien or whatever ^^).
it is charging and i also tried 2 different micro usb cables but without success.
i use windows 7 so i should not need any software on the pc but i also tried it with (i installed one for universial android phone users but was no use) i also have no memory card for more gigabyte.
have u any suggestions what to do?



Hello Thomas,

I had the same problem as you. Since the last update I could’nt connect my phone with the PC. I’ve tried different USB cable and it didn’t work. So I finally switched off the fairphone and started again: I switched it on again, and I connected the phone as a MTP. The my pc found the fairphone!!
I hope this could be helpful for you…
Good luck!


Hi, I have the same problem. It is charging when connected with the PC but nothing else happens, the pc did not find my phone, neither the phone find the PC… It used to work, but now nothing. My phone has been updated but this problem was happening before the update. I tryied different cables (three or four) no difference.

Has this issue been resolved? I am having the same problem. I want to update the software but it wont connect to my computer, I use a pc. I have tried numerous cables and although my phone charges, there is no option to change my USB connection in the notification panel. I really don’t know what else to do, I have hunted everywhere trying to find a post that might answer my question and have found nothing. Please get back to me soon, I am very frustrated and almost at the point of just buying another phone so I don’t have all these issues, which is disappointing.

What have you done already to resolve the issue? Did you try the solutions mentioned in this support article?

Yes I have tried this. The USB connection option doesn’t come up in the notification section and the USB internet section under settings is completely greyed out.

Does your (Windows) PC recognize that you plugged in the Fairphone?

No, the PC does not recognise anything has been connected. I have tried this on two computers, both are PCs. When I look on ‘my computer’ it does not recognise anything has been connected.

Click on the Windows logo in the down left corner and type “device manager” and open it. Then choose “USB devices” (or similar). Is there an entry, which says e.g. “unknown device” or “???”.

If not:
Since you say, that you tried with various cables and PCs, it has to be the FP. Things to try (read carefully!):

  1. Manually install Fairphone OS 1.6.
  2. Do a hard reset.

Hey i have the same question! But now my phone is updated to Kola Nut 1,8, should I still install OS 1.6? Also does the hard reset remove all the data in my phone? such as notebook etc? It used to work before the update, but now i even couldn’t find the USB connection button in my notification panel? Thanks!

Then you should downgrade to Fairphone OS 1.6. If you run into troubles with an error saying “ has stopped”, follow this link.

This post of mine from some time ago might also help you clear up the situation:

I cannot manually install the OS as I cannot download the file to the the
phone from the computer as it doesn’t connect, I think I will just have to
try the hard reset.

I’ll let you know how that goes.

Try to navigate to the download page in the browser of your Fairphone and download Fairphone OS 1.6 directly to the Fairphone.

The upgrade worked! I made a backup of everything to an SD card, I then
downloaded the files directly to my phone from the web browser, I had to
hunt around the folders to find where it had downloaded to, but got their
eventually following the manual process you suggested. I now need to check
whether it has fixed the problem of not being able to connect to the

Thanks Stefan.


Hi there,

I have the same problem as described above. The computer (Mac) does not recognize my FP at all. It charges though, so it the connection should be okay. I have already restarted my FP. I have tried different USB portals, but none of them work.
I kinda fear a hard reset becasue I will lose all my data. Downgrading to OS 1.6 could be an option, but it is quite a hustle to downgrade, connect to my Mac, and upgrade again.
New possibilities to solve this?

Hi, I’m Carly, a Fairphone-fan but now having somee trouble connecting the FP to my Windows laptop (in order to transfer music to the FP). The laptop doesn’t recognize the FP, neither is it visible in the ‘control devices’ panel of Windows. The support artice says that ‘in the notifications panel, I have to select USB’ however my notifications panel doesn’t give me this option. What should I do, apart from trying a different cable? Many thanks for any useful tips…

hi, I have been reading a all the options, and I do not want to downgrade my FP or to do a hard reset. I already did this a few months ago to get more storage room, and it was a lot of work to set everything as it was.
Are there any other solutions? Any apps to download or so?

thanks a lot!

Hi all,
I just created a tutorial, how to copy file to your phone wirelessly. Here it is:


A post was split to a new topic: Can’t copy files to the internal storage via USB