Connecting bluetooth-headset takes longer and longer since last reboot

When I reboot my Fairphone4, connecting my bluetooth-headset is basically instantly when I switch it on.

However, after a fed days it begins to take longer and longer time. It just grows and when it takes 30 seconds or more I have to reboot the phone, and it is back to connecting instantly again.

This happens every time, and has been so since I got the phone i February and remained after the latest system update.

Is this a known issue?

Welcome to the forum!

I assume that you’re on the standard FP OS and not some custom ROM? Did you install the recent upates?

I’m using a bluetooth headset with my FP4 all the time, plus occasionally some other audio devices and cannot confirm this problem.
Do you have any other bluetooth devices to cross-check this with?

Rebooting now and again is not necessarily a bad thing, for any system.

Did you check whether this is a known problem with the headset?

You might delete the pairing on both devices1 and start again.

1 - It is normally possible to delete the pairings on the headset, though in general this will delete all of them. Check your user documentation.

@mde : Yes, standard OS and I always make sure to be updated when troubleshooting.

@OldRoutard : Agree about rebooting now and then is a good thing. I do that too.

It seems my issue was resolved with a factory reset of the Jabra headset. Since then it has now paired up flawlessly for a few weeks.

Thanks for your help.

4 Likes

Hello!
I have the same issue of tsvenson.
Indeed, I pair both Google Pixel Buds and Amazon Buds 2 with my Fp4 and happen the same problem. Often those headsets need more than 20 seconds to connect whit. It happens also with my Fossil Gen 6 smartwatch than notify on late than the notification received on the smartphone.

Do somebody know about this issue?

Hi Mat1982 and welcome to the community and the forum !

Have you seen my suggestion above, and reset your headsets and deleted the pairings on the FP4? You can then pair the devices afresh.

tsvenson said this solved the problem for him. It might also help with the smartwatch.
In the case of the smartwatch, some ideas:

  • are you using any battery saving options?
  • there is presumably a polling interval for watch / phone that might be ajustable
  • make sure battery saving mode is not enabled on the phone.

Hi OldRoutard,
I tried everything you wrote and nothing resolve my bluethoot connections problem with both headsets. I don’t know what I can do to resolve it. Can it envolved with the 5G issue? On my device, if the “5G/4G/3G/2G” taggle si activated, often and randomly Fp4 restart itself.

All the last update are installed on my device and I dont use battery saving options.

I hope in some solutions because I love my Fp4 and all the philosophy around it but I use it for my work and are very important for me the true-wireless headsets and the 5G connection.

Thanks!