Clock resets when I take the battery out

Now that’s strange: if I take out the battery, my phone resets to August 2013. I have to go to the settings and set the time manually. I noticed I had to set the time and date every time when I took out the battery since my phone was serviced by FP/ (parts of the display were not reacting), but in all instances, I took out the battery for quite a while. I just assumed the capacitor ran out of juice.

But now, I took out the battery just for a moment - and it also happened.

Am I missing something?
If the capacitor is broken, I doubt I can fix this myself, can I?

I think this is normal behaviour. It happens to me too.

I don’t think there is a backup battery for the clock so it should be normal.
You can also set an option in clock settings to get it updated by network, so when you get GSM/3G signal the clock should update itself automatically.
You can also use SatStat to get the system clock updated by GPS :smile:


This happened for me with another smartphone as well. I remember that with older Nokias, you could take the battery out for some minutes until the clock reseted.

I got hold of a second Fairphone and tried it out, and it’s not normal behaviour. Simply does not happen. It kept date and time.

What @ben says: you should be able to take out the battery for at least several minutes. There’s a capacitor inside, remember? It’s one of the parts which we bought the phone for - because it’s a fair capacitor.

I know that I can use both GPS and mobile network provided time for automatic date & time adjustment. However, this does not kick in immediately, of course. Also, since I scheduled several actions on my phone depending on date & time, some of them are triggered when I manually adjust the time.

Did I maybe miss something else?
And how can I repair this?

Maybe, since you state that the problem started after your phone had been serviced by FP, you should contact FP support and tell them about the issue.

The capacitor is part of the motherboard, am I right? So you would have to change the whole motherboard…

1 Like

Had a look at iFixit, and noticed that there is also a battery (lower right corner in the pic) on the mainboard… maybe that’s the culprit? Would be better than the capacitor (which I did not locate on the pics, on a quick glance, yet). Going to contact support about this, cause it’s really odd…


WOW! It seems I was wrong! Good catch! :smile:

Yeah, that could be it! :slight_smile:

Bad news, everyone. I asked FP customer support for info. Long story short: it’s likely the cell battery on the motherboard is out of juice, defunct, or whatever. And it seems you can’t replace the on-board battery without soldering - which is a total bummer.

I have to send in my phone.
Again.* Oh noes.

(*) The problem started after my phone got serviced in November, but I only realised recently that it was a) persiting and b) disruptive.

Good news, everyone! (Hah, this never get’s old!) I have lots of love for the Fairphone support team to share: I sent in my FP1 and got it fixed on warranty. It arrived yesterday - and I even managed to let the package sit for a while before opening it. Checked it, the ‘clock reset problem’ is gone.

Thanks, Esmée, Ramon, and whoever else was involved! :heartpulse::iphone::heartpulse:

Important info for everyone, which is easily forgotten/overlooked: after getting your phone back from repair, you have got three months warranty on that repair, so even if you would be running out of the normal warranty period, the extension would have you covered.

Sadly, as mentioned above, the on-board cell battery is non-replaceable (without soldering), and Fairphone has no spare parts (i.e., no cell batteries to swap for those). Support told me they had to replace my motherboard. (I actually haven’t checked if IMEIs and MAC are now different, I really just opened the box and checked if the problem was gone. I might notice soon enough, and expect some trouble…)

Bottom line: I consider this non-replacability of the buffer battery a serious design flaw, and hope this will be avoided in the FP2.

I would have loved to get the old motherboard back I asked, but so far Esmée and Ramon didn’t react to that request. Apart from the battery, is was functioning well.

I would have kept it for tinkering and as a backup if mine ever had more serious problems. I’ve also got a friend who is seriously giftet with electronics, and he would have loved to play with that motherboard! (He probably would have immediately tried to interface it with an Arduino to use Nixie tubes as a display… Ok, that was just guessing.)

Now, I have to set up my phone again. But first, since it’s reset anyway, I shall apply to become a beta-tester! Yay!


Glad to hear it’s sorted.

It does sound like a complete waste of resources if the battery can’t be replaced independently to the motherboard, but then we have to remember that the FP team didn’t design the internals of the phone, it was a licensed design. I guess for the FP2 the team are going to have a lot more control and the freedom to make these design choices. Let’s hope they do :wink:

BTW, have set this topic to auto-close after 7 days from the last response.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.


recently my FP1U “forgets” the actual time and date if I take out the battery.
It looks like that the internal battery on the FP Mainboard is not funcional anymore:

As the internal battery is fixed to the Mainboard:

As far as I noticed only the clock resets. Are there other impacts if the internal battery is empty?

Does anyone know if it would be still necessary to change the whole Mainboard to replace the internal battery (as it was written in the post it mention above)?

I guess that in specialized phone shops with very small soldering stations, they probably can replace that battery.

My clock resets as well. I always try not to power off my FP1, but if it’s unavoidable, after setting date and clock again, I haven’t noticed any other impact so far.