Charging the FP2 / cable problems

It’s neither the charger nor (probably) your phone. A special charger cable is all you need: At the USB-micro end data pins #2 (D+, green) and #3 (D-, white) have to be shortcircuited or shunted by less than 200 Ohm rather than fed through to the USB-A end.

Why? Some devices (so does FF2) need above pin connection to recognize the device at the other end as a charger. Some chargers offer that option, others do not (obviously yours). So not everybody would have a problem with using their old chargers with an ordinary data cable.

Such charger cables are rare. I found one product.

Otherwise it’s not difficult to prepare one yourself. Cut open the cable, cut through the green and the white wire. Connect it or insert e.g. a 100 Ohm resitor at the USB-micro side. Cover the connection properly. You can find a nice instruction here. Or cut off the USB-A connector and replace it by a one to be assembled by yourself. Treat the green and the white wire as above rather than to connect them to the pins. That’s what I did. And–wow!–all six chargers which troubled me before worked gracefully.

I wonder why FF’s engineers didn’t stumble over it. Or if they did, why FF do not communicate on the subject. It could have saved a lot of frustration by telling customers about the reason why their chargers won’t work and giving them advice how to work around the flaw instead of oddly suggesting to buy another charger (as they did, when I complained about the failure with all my chargers). This counteracts the idea to deliver the Phone without a charger because most people have one or several in their drawers. Instead FF should offer appropriate cables as an accessory. Or even add it to the phone.


If the charger or the phone is not following the USB standard, I would say it’s still the charger … or the phone.
Is this article similar? And is shorten the lines the same as up to 100 Ohms? I think you found a good solution here, but I’m not sure yet what causes the problem.

It’s either the phone or the charger that are not following the specs. The charger is easier to fix. But I think FP should publish the specs for the usb charging. I ask for those a while ago but I did not get an answer. I assume the right voltages on the data lines are important to trigger the right charging mode.

Apple Example

Thanks for your valuable links, which put a bit more clarity on the scene. (Some guy of a certain company once said, “We absolutely agree on the value of standards, hence we too are eager to cultivate our own.”).

Re your question: It seems that more or less only the logical level (“0”) counts. After reading the notes about apple we may suspect, that the resistance value may influence the max charging current. To prove this may need a little more research. (With my arbitrarily chosen 100 Ohm the FP2 works with sources from 0.5 Amp laptop to 2 Amp iPad charger).

Interesting. I read that Qualcomm does their own charging magic (Quickcharge) but as I said, I don’t know the specs. I also heard that even if the feature is not sold, they somehow switch it off by software. But maybe that are just rumors.

Maybe some charges (the shortened ones) confuse the system? But according the specs … the phone should still charge slowly … (“up” to 100 Ohms … I assume that shortened is below that :slight_smile: )

But yeah, that’s nitpicking about standards. But it would be nice to know what values the internal Qualcomm charging unit (there is a term for that …) accepts.

check if the battery is inserted tightly! cause in my case simmilar problems…

Furter check every screw and contact of your phone ( they need to be tight)

May be this will help you. The most issues are caused by bad contacts.

1 Like

In my opinion it makes a lot of sense that you need a even higher current capacity of your charger if you have a bad contact on the battery or any where else. I think also the screws who tight the conector of the usb modul could also be loose and cause that there is a very high resistance and therfore a drop of voltage and heat. You are acually heating your enviorentment when you have bad contacts… That’s may be not the goal of chaging your phone ;-).

What that means is that if you do not have good contacts in your whole chain (usb, module contact to the mainboard) you will need more power to be able to charge your phone… So I can not say it enougth:

Check all screws, contacts, and make shoure your battery is thight inside the phone (good contact to the contact pins) and make shure that all contacts are clean. I am very sertain that most problems that people encounter with FP2 are caused by lose screws and bad contacts… Alsow make shure that your usb cable is not wabbeling around. I had a cable who’s quality was very bad and therfore the contact was not good enougth.

Hope this helps!

Same problem here, batterie life is not that good, but since yesterday, I can’t charge my phone properly, it’s just connecting and disconnecting. It had no problems charging from the exact same setup before.

1 Like

Same problems as Alice.
It has charged without problems until couple of days ago that connects and disconnects. I’ve tried 5 different cables.
Any solution?

I’m quite disappointed with my fairphone because all the problems (charging, microphone…)

Hey everyone - not sure how helpful this will be, but after replacing the bottom module (my microphone was also not working), the phone is now charging fine. So in some but not all cases it may be that your bottom module is simply not functioning correctly any more, for whatever reason.

1 Like

I also have huge problems charging my FP2.

I only have the phone for 1 month and previously I had not any problems charging it with either of my chargers or my computers. I think it started one or two days after the battery was totally uncharged.
Some days before the phone also fell down while being connected with a cable. This could have caused some mechanical stress to the contacts and/or to the whole phone.

When I plug in the charger cable it might start charging. I might be able make it charge by wiggling the cable. But after a while the charging light will go out eventually.
When I remove the battery and try again the phone might go into the endless loop of “Showing the Fairphone logo”, “vibrating”, “Turning off”.
Maybe there is a mechanical problem with the contacts. I tried several cables, chargers and phone positions but it seems to be random. Eventually the charging light will go out without me touching the phone or cable.

When I can get my phone to charge there might be another problem because the phone can get very hot and uncharge the battery. I tried to reset the battery as described here and this seems to have helped. But I had to re-do the resetting quite often. Sometimes it only charges for 5 to 10 minutes before I have to reset it again. The last two days I was able to charge my phone but it took the whole day because of the 1/2 hour waiting time recommended.

This obviously makes my phone unusable so I would be really appreciate some suggestions how to proceed.

Edit: It seems that charging works best when removing all SIM cards and the SD card and charging from the USB port of my computer. But this make the phone even more unusable because I cannot turn it on while charging and it takes longer to charge.
BTW: One of the SIM cards is quite old and I have cut it myself to make it fit. But this wasn’t a problem before and also this card works flawlessly on my other phone.

It could have something to do with your sim-cards.
Where are you living and who is your provider?

Switzerland. Providers are Swisscom and Sunrise.

I just checked my phone again which was charging since my edit which was about 4 hours ago. It is very hot and the battery is only half full. Also I think the charge level did not change in the last half hour. But the charging light was on the whole time and changed from red to white/yellow.

At the moment, no SIM or SD cards are plugged in and the phone is not turned on, so the problem must be somewhere else (also). Why would a phone CPU be so hot when it is only charging the battery?

Edit: Four hours later and the battery is uncharging while the phone is plugged in and although the charge light is on and the charging animation is running. This is just silly. What is my phone doing that it uses more energy then it can draw from the charger?

It’s indeed strange.
Although the charging light is good. A red light for a flat or very flat battery. White/yellow after some charging and it will be green when the battery is full.

Perhaps you could try:
Boot your phone and go to Settings, Battery and hopefully you will get a clue which service is consuming to much energy.

I don’t understand your suggestion. If the phone is turned off, there should be not a single service running or am I missing something.

Yes, if the phone is turned off, there should be not a single service running.
But your phone is behaving very strange.
That’s why made my suggestion.

OK, I will look at it. But I cannot do it right now because I did a complete reset to see if it could be caused by some app or setting.

Sadly the problem still persists. I removed the SIM and SD cards, turned the phone on and connected the charger. The charging light is on and the battery symbol shows that it’s charging and the battery level is 83%. Half an hour later the light is still on, the symbol is still showing that it is charging but the battery level is at 77%. Also the CPU area is very hot.

Edit 18.09.2016: I was able to find two problems. I replaced the bottom module and now I am able to charge my phone again. The other problem was the charger, apparently it stopped working reliably. The phone still is quite hot while charging so I will investigate this further.

1 Like

I’ve got a similar problem. I think it’s the connection point, that’s broken. I indeed can charge my phone properly if I take the charging cable and wrap with force around some little box AND the phone - then it charges :open_mouth: But I broke 4 chargers that way until now. (At least I can use my phone sometimes - unfortunately it doesn’t always work).
I wrote to the support 3 weeks ago, but up to now: no answer. :disappointed: (But I should be used to that now: My phone completely broke 3 month ago and it took the support a whole month to answer me… I’m just a patient person and perhaps sometimes glad if nobody calls me :wink: )

Hello everyone,

I´m new in the forum, so hello everybody :slight_smile:
I have my phone since 1st of January. Last week the charging problems occurred.
I experience the same problems as Alice_Lieutier describes. Same charging setup.
While writing this text, my battery dropped from 16% to 10% while plugged in.

Hello there!

I’m getting more and more frustrated with the phone. :confused:

The new problem started like a few days ago, when I plugged my phone into the charger.
It seems (somewhat random kinda) that after a bit of charging the phone just stops charging or even goes to a charging to non-charging loop.

First thing I tried was obviously to test other chargers and other cables, but the problem was still there.
I’ve inspected the USB port on the phone for dirt etc, didn’t see anything in there that would cause a problem. Taking the module out and reinserting it also didn’t make a change.

I’m puzzled… obvious troubleshooting didn’t help me, so I’m asking you if you have any tips or if you noticed similar issues with your phone. I’ll probably open up a support ticket soon, but meh, christmas is around and you all know how it is around that time with support and shipping replacement stuff…

I have also this problem:

You probably have to buy a new bottom module to solve this problem. Unfortunately, they are sold out, and nobody knows, how long.