Charging the FP2 / cable problems

Did you actually try the solutions given in this topic? Yes, it’s a long topic. But it’s really worth reading if you actually want to find a solution.
Otherwise, it’s also possible your usb-port has a problem. In this case, self-repair or contacting support seems more appropriate than complaining about a closed topic…

Only reason this (moving the posts) didn’t happen was to avoid duplication of the responses below (as they were already present in the target topic), and an attempt to keep the discussion on-topic. Given the responses (see below regarding point B), my impression was that moving the posts wouldn’t have a positive effect on the topic the posts would have moved to. Closing the original topic obviously didn’t work to keep everything on-topic as now we’re discussing general design flaws in very general terms (point C in the post above) without a clear or realistic expectation of what people hope to achieve.* Keep in mind that the existence of the other topic is already enough to close a topic, see the list of reasons to close a topic here.

What I actually wrote:

I’m not saying the post is abusive (otherwise it would have been deleted), rather I’m saying that other than the appropriate answer about the cable type, the responses that the topic was getting were missing the problem. Moving to the relevant topic would keep this more on-topic. Perhaps it was slightly early to conclude that the topics was veering away from the original problem, though I don’t often have a ‘I’ve seen enough topics to know where this going’ reaction to these things. Again, the fact that there was a topic dealing with the same issue, makes it an obvious decision to close a topic that is attracting off-topic responses in favour of the established and useful earlier topic.

Regarding C): I’m not saying the Fairphone hasn’t got its problems. What I do want to do is help those that want to actually solve issues they have as best as possible with what they have now a chance to do that effectively. For me, this means structuring the information as best as possible to help people find it.
Related to that: None of the community moderators work for Fairphone. Personally, I’m not too concerned with whether they sell one phone more or less, or whether there is a return more or less. That’s for Fairphone and customer services to worry about.

If there is a need to discuss forum Moderation further, I’m happy to move this and some other posts here into a topic in #meta . Similarly, feel free to start a topic in #meta to discuss how the forum rules could be better.

*I’m perfectly happy for a constructive discussion about how matters can be realistically solved. I’d normally go for a per-actual-problem approach, but if anyone feels there is need for a discussion about the general state of the Fairphone2 and can frame it in a constructive manner then, please, do go ahead. Come to think of it, I’d even be in favour of a topic where people can rant/vent all they want (within the forum rules) if it means the rest of the topics stay more on topic and constructive.


Might be a good idea (if bandwidth/server space allows). I’m a member of another forum where the section with most activity/posting is labelled “Off Topic Chat” where people can open threads about anything (including pointless daily countdowns to Christmas, the UEFA tournament and so on),and where mods are tolerant (allowing them to strike down on OT posting in other threads).

1 Like

Here, the best category for such topics seems to be #community, but I’m not sure how tolerant most Moderators are. I do think posts that ask questions about how to x,y or z on other phone brands are usually replied with a polite suggestion to find a more relevant form and are then hidden, for example.


I received my Anker 2A charger today, kept the battery out of the phone for 2 days.
Trying to kickstart the battery produced no result.

I still have the same problem I described earlier.

You asked if I ever had led the FP2 go powerless before. Yes I did, but not when it was attached to a charger and the phone drained while it thought it was charging.

Currently I’m out of options and this started almost a week ago and I have spent close to 8 hours and 25 EUR on this issue.
Are there any fancy debug option available while the battery charging app is only running that I have missed?

Otherwise someone from Fairphone could take a look at the phone?

Maybe the list of chargers used by community members is useful in this discussion:

I’ve been charging at a Windows computer via a USB2.0 port using the data cable that shipped with my old Samsung Galaxy. I had many of the same problems described here (CPU very hot, lightning bolt and LED flickering, phone not really charging), but I wasn’t experiencing problems with rebooting or functionality.

My incredibly lo-tech solution was to plug the cable into the phone, put it down, THEN plug the cable into the computer. It then started charging happily, but it goes wrong when I move the phone, until I repeat the process described above.

This strongly suggests to me that my issue is with the connection. I’m going to test with another charger when I get home to see if the issue is with the cable or the phone. Given that this cable worked perfectly with my old phone, I suspect it’s the FP2 (unfortunately!).

1 Like

So the solution for the charger issues seems to get rid of half of my chargers and usb cables? Really? And not to forget to buy an new car, the FP2 is not charging from the cars usb port :wink: i know i can buy such a lightning port usb adapter, but why? There is already a usb port. Every single USB device in the world is charging from all of my chargers/cables, except the FP2. Sorry, but that are workarounds, no solutions.
Are there any plans for further improvements (not to use the term bug fixing)?

Try to use a data cable from your car usb port to the phone.
In my case using a data cable got my phone charging in the car.

Thanks for the answer, i will try when back home.
I did try different cables, also one which has worked by using another charger, nothing did charge the FP2 in my car. But that was before 1.2.8. I will try again and hope the best.


My FP2 is not charging today at all. Because I only have one (out of 5+) USB cables that can actually charge my FP2, it wasn’t charged overnight and is now off. When I tried to charge it this morning (using the cable that was charging it yesterday with my pc), it will not charge at all. No charging light, nothing.

What can I do? I am frustrated :rage:

Take a look here.

Thanks but it turned out it was fully charged. I reseated the battery and turned it on… to find the screen was broken. There is LCD damage indicated by rainbow lines on my screen. Bearing in mind I disassembled it exactly how the official Youtube videos did, I’m really disappointed in this product.

I have again tried to charge the FP2 at the USB port of my car with 3 different cables, still no charging. Theese cable charge the FP2 by using other chargers but not in my car. Very, very disappointed. There was a little hope that charging issues are better with 1.2.8. The frustration level is getting higher and higher (SIM killed, bad BT audio, charging issues, …)
Of course i did a test with an other USB device to check that the USB port is OK.

When you connect to the computer and you tap on the screen showing charging, are you then getting the possibility to switch to other options?

Yes, i can switch between modes when connected to a PC (same cables). But it is not charging in charging mode, i have to switch to MTP or something. And then it is charging very slow, about 1% every 10 minutes (with the PC). I’m not sure, but i belive this is new with 1.2.8.

It is charging! Because of your tip i have again tried to charge in the car by using different options. It is only charging in the mode mount SD-card. On my Notebook it was in all modes but charging mode charging. It is just a small step foreward, but now i have a workaround for charging my FP2 in the car. Thanks for your support.

After replacing the microphone module of the FP2 and replacing it, the FP2 now charges normally.

Thanks for the quick response.

1 Like

Thanks for mentioning that wakawaka and FP2 get along :relaxed:

sorry if my question has been answered already, but didn’t want to read the whole thread:

My cable charges my FP2, but cannot get a data-connection with my computer. Fairphone sells cables and chargers, but they are only categorized as ‘FP1’. I reckon thic cable/charger also works with the FP2, but wanted to know for sure, before I order.

Can anybody confirm that the FP1-labeled charger/cable sold in the shop is compatible with the FP2?