English

Charging the FP2 / cable problems

I have the same problem, the front screen says that the phone is charging, but if you look under settings > battery the phon e is not chargeing. I can only charge if I close the phone completely down! Most anoying!

htc Adapter, Model TC E250. Output 5V, 1A max only works if the phone is shut down

I’ve got exactly the same problem, I too have to rely on using my laptop to charge my phone.

I’ve bought two chargers now, both specifically 5V 1A output as requested and have had no luck. Interestingly they both initially worked fine but after an initial charge the charging light on the plug turned off and won’t turn back on and now the phone doesn’t charge at all from them (I’ve yet to check if they will charge another phone as all my housemates have iphones). Could it be that my phone is somehow ruining the charger? They were both brand new albeit not the greatest of quality but I don’t know much about these kind of things. One was Currys Essentials model CUSBCH12 and the other was from Carphone Warehouse model TCBE40CABLE-1A. The Currys charger doesn’t have an inbuilt cable but the cable I used with it is the one that works perfectly with my laptop so I expected it to work fine with the charger…

@AnnaD did you have a similar experience or did yours not work from the start?

Has anyone else come across this?

Hi,
I too experienced charging problems. The phone worked for just three days before being rendered completely nonfunctional. The charger I was using has been purchased from Fairphone specifically for my new FP2. I was left with no means of mobile communication and no access to the information on my sim (contacts etc). Given the limited customer support that was available (up to eight working days to reply to an email enquiry seems poor) I opted to return the phone. Very disappointed to be honest but given the number of other posts on here describing similar experiences there is clearly a problem and I think I made the right decision.

1 Like

Hello,
also to me it seems my FP2 is sort of picky, when it comes to charging.
I tried several combinations with sometimes astonishing results:

  1. USB-charger with my “charging cable” (a broken data cable, which I used to charge e.g. my headset or my (company) S4 mini.) Seemed to DIScharge my FP2. (That’s been my very first try and first made me believe I’ve got a broken battery :frowning:
  2. Same USB-charger, but different cable: Worked.
    (I then dumped all cables NOT working to spare me the confusion.)
  3. Data cable working with the S4 mini + USB-port on my (company) laptop (running Win7): Charged with FP2 switched on; but having the FP2 switched off leads to a “rolling reset” of the FP2. It comes up with the charging animation; this goes through one cycle, then the FP2 restarts. This repeats seemingly endlessly (tried maybe 5 cycles). I think I tried to set the FP2 to charging mode/MTP/PTP before switching off - all with the same result.
  4. When I tried yesterday to charge on my USB hub, it didn’t work with two different cables, both able to charge the S4 mini. (FP2 showed no charging symbol.)
  5. Funnily when I tried just now, it worked. (The difference I’m aware of, is the fact that currently the FP2 is 89 % charged, but it was much less then I tried last time)The AC-plug of the hub is specified with 5 V / 3.5 A (sounds more than sufficient)
  6. One of these cables, but used with the AC adapter for the laptop (which has a USB-A plug of its own) worked - also with a charging state of < 40 % on the FP2.
  7. A very slim USB-charger with fixed cable (borrowed from my sister) worked.

So all in all the FP2 seems to be picky. It’s hard to tell what will or will not work.
This is currently my biggest day-to-day hassle with my FP2…

Regards

Martin

A post was merged into an existing topic: Fairphone 2 unusable while charging

Unfortunately it is no new issue, as you can see here.

However, there is not yet any fix for this or an official FP-statment.
In my case sometimes it helps temporaly to just unplug and plug-in again the cable.

@moderators: we should move this topic.

@Colley, thanks for the advice - mine has been pretty consistent about not charging away from a computer, and from the start. However, I bought a data cable and that seems to do the job. However, if I try to do anything on my phone while charging with the data cable, the phone crashes and I have to remove the battery and restart it. Again, it behaves consistently badly in this way - but at least I know and will remember to unplug before doing anything. It works fine while plugged into any computer via a non-data cable and doesn’t crash.

Thanks all for the advice.

Sorry, cannot reproduce your error. Have you tried different cables?

i have more or lesss every problem there could be with charging:

  • the fp2 keeps going out of standby by itself, sometimes it discharges, sometimes it charges
  • the fp2 does only accept certain cables and certain chargers
  • the fp2 is unusable while charging. because it doesnt react to display touches
  • the fp2 is unusable while charging, because the display goes lunatic per touch
  • the fp2 is unchargeable after it reached 15%. i have to compeltely shut down the phone and charge it (sometimes, it statrted up by itself after charging)
  • sometimes i believe, the charge-state isnt honest. eg when reading, using the same app: one time i can read for hours, another time i have no force left after reading for some minutes.

i really would like to know, why it is like that and what i can do?
i really wanted the fp2, i didnt send it back, but as sad as it is: after experiencing, more or less approx. 5 bugs from the beginning, i cannot recommend it.

I found out that I can’t turn on my FP2 while plugged in. Only the charging animation appears. To turn on the FP2, you have to pull out your charging cable.

Just a short update here, we have broaden the charging range for the Fairphone 2 with the software update 1.2.8 (now available to everybody).

I have also updated the poll with the software version and the “touch screen usable during charge” so that if anybody still experiences issue, you can post an updated response.
Thanks again!

hey wolfie,

For the first issues, I would like to know if the software update helped you.
For the last two ones, have you tried to kickstart the battery?
If your issues still happen, please send a request to support (and PM me your ticket number) with screenshots of the battery report (both regular and detailed, when you click on the battery graph).

tofra,

same thing as with wolfie, could you please report after updating to 1.2.8?

I am so happy, after the update my phone is charging with my old charger. :relieved: :ok_hand:

2 Likes

It works, but you have to press the power button much longer than usual. (I have not tried such a long press before the update.)

I did and all the time, I had to press it longer as well - looks like normal behaviour.

hi borjan,

i tried a battery-kickstart already and it didnt help - but the update did!
magically, it works now to use it, to use every cable, to load it without random startups, i would say: its working flawlessly!
thanx a lot and keep up the good work!
now i am able to recommend it :slight_smile:

2 Likes

Hello,
update to my post.
I found one interesting effect (“old” FW):

When I had my FP2 switched on and connected to the USB port of my laptop, switching from “charging mode” to
to one of MTP || PTP (probably PTP) changed it to "not charging"
Sorry, I don’t have the mode, because when I tried to reproduce I wasn’t able to do so. So this only happened once so far.

Then I tried more systematic on the “rolling reset” issue: (All with the FP2 connected to my Win 10 laptop)

  1. FP2 switched on; connecting to USB
    MTP – charging
    PTP – still charging
    charging – still charging
    MTP – still charging
    Off (while in MTP mode) -> rolling reset

Same ending in PTP
Off (as PTP) -> rolling reset

On my first try with the new FW 1.2.8 it seemed in one case to be more picky. Same cable, same USB port (the USB port of my Fritzbox, because it needs standby current anyway,) Here it seems to barely load while switched on, instead the FP2 got warm (something warmer than body temperature, not hot) This had been better before. (Or it depends on some other factor which I didn’t recognise so far)

Martin

P.S.:
Just to spell it out: I’m happy with my FP2, despite these problems. (Other here say it’s a show stopper)
I didn’t expect it to be perfect. I surely hope that FW updates fix some of the drawbacks.
But I like it nevertheless. I got what I wanted; I wanted that smartphone also as a “political statement” (electronics can be done better); at the same time the decision “feels” correct and I’m partly amazed of how (and how often and for what purposes) I use it.
I had several (smaller) decisions to buy stuff, between the pre-order of my FP2 and now. (no electronic gadgets)
There my “requirement analysis” seemed to have been incomplete and I had been somewhat disappointed. The FP2 was one of the bigger decisions done right from my POV.

1 Like

How long is this longer-than-usual press? Two seconds? Fifteen seconds?