Change the camera App which gets started with the camera button in LineageOS


Since the LineageOS stock camera App seems to have some trouble with the flashlight of the new camera module, and Open Camera seems to be better anyway, I installed Open Camera.
And now I would like to start Open Camera with the camera button, but how?

I managed to set Open Camera as the App that gets started when swiping the camera icon on the lock screen by resetting the defaults in Settings - Apps - Camera. Then I was asked for the desired App the next time I swiped the icon.

Alas, in LineageOS that doesn’t seem to do anything with the camera button, as it would do in Fairphone Open OS.
I can’t deactivate the stock App, and I can’t uninstall it the easy way* (I can try, but it always says uninstall failed).
I first disabled the stock App’s permissions to access the camera, that at least prevented the App from getting started with the camera button.

*I then managed to uninstall the stock App via installing Open GApps again with a gapps-config file that tells the installation to remove the stock camera App in the process. Neat feature :+1:, the stock camera App is really gone.

But even without the stock App being there the camera button doesn’t ask for the desired App.

What can I do?

1 Like

Strange, I did deactivate it and I can open Open Camera with the button.

PS: In Settings -> Buttons under “Camera buttons” my settings are “wake device” disabled & “launch camera” enabled. But I think that’s the default setting.


Thank you! That’s it.
These were the settings initially, and I probably never would have looked there again … now I looked and found “launch camera” disabled.
Enabled it again and the button indeed starts Open Camera now :+1: .