Change MAC address on FP2?

Hello !
I’d like to change the wifi MAC address on my FP2. Does anyone already succeeded with that?

  • On this forum topic I found this topic for FP1, they managed with “ChameleMAC” app, but this app is not compatible with FP2 (for MediaTek processors only!)

  • I tried those instructions but without success:
    ip link show
    ip link set wlan0 address XX:XX:XX:YY:YY:YY
    ip link show wlan0
    Even if the last line display the new address (I changed only the last 6 characters), when I go to Settings > System > About phone > Status > WiFi Mac address, it’s still the old address !

  • I found another method with busybox but I don’t have it installed.

Afaik to change it permanently root access is mandatory. Otherwise a change is limited to the actual running session until the next reboot.

I have used the termux app to use this command:

ip link set wlan0 new MAC address

Is that data actually updated each time the settings panel is opened? After you run the commands that show a changed MAC address, do devices that you contact over Wifi (e.g. your access point) see the altered or the original MAC address?


When i type that, I have an error message:
Error: either "dev" is duplicate, or "84:cf:bf:66:66:66" is a garbage.
That’s why I typed ip link set wlan0 address new-mac-address

I tried today. Strangely, after the mac change, I couldn’t connect anymore to my router, even with several trials. I then launched airodump-ng on my laptop to capture the network, and it detected… both new and old mac addresses ! I looked back to my FP2 and it was now connected to the router, with the old address ! So the mac change lasted for 5-10min then somehow reverted to the real one by itself :wink:

We had this topic some time ago.

I tried this command “ip link set wlan0 *new MAC address” from here where it reads:

But to be true, I cannot reproduce any useful result with Termux or Android Terminal emulator now.

After entering any of the above set… commands both terminals simply freeze without any result. I kept this command for some time in my archive but did not test it thoroughly. Although it should work on non-rooted devices it does not look like being of use for me. :neutral_face:

If it’s only for home use maybe your router has such an option built in as mine has.
For on your way maybe you have to accept installing a specific app as listed and get root access. Btw. altering your MAC without root is as I could read only temporary until the next reboot. But I guess this would be ok to have it on a per- session basis.
Sorry that I could not contribute more here.