Change is in your hands screen stays for ever


I’ve been using my Fairphone 2 since October 2017 and always ok. Today I had to charge it with a different cable and after that when I turn it on it keeps showing the ‘Change is in your hands’ screen over and over and never starts android. Any suggestions? Thanks

I believe meanwhile you have rebooted your phone? Does it now operate normally?

Hello Amber,
I have rebooted it several times. Tried to update the OS with linux and windows. Linux stops at validated files, windows doesn’t find any fairphone in any port. Morover I have fully discharged and fully recharged the battery, opened the case and checked the buttons. Rebooted from the robot icon. Well, everything I read on the support page and forum but hard reset, cause I dont’ wan to loose some data. I think the phone sould be mostly ok, LED color sequence is ok when charging, but it gets stuck on the ‘Change is in you hands’ logo and no more. Once it runned a process: It showed a white band where it said ‘starting Android’ and it started updating sequentially and very slowly 138 applications (that’s what it appeared written) . But after that it kept showing the same logo and doesn’t allow me to do anything. Well this is the full story I guess. Any idea is welcome.

Do you still get into #dic:recoverymode? There you could try a #dic:hardreset, but you’ll lose your data.

I wanted just to let everybody know that I was eventually suggested by my distributor to send the fairphone 2 back to Netherland. I did that and I have just received my phone back …and it looks ok. Moreover, I didn’t lost any data on it.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.