Can't unlock oem


I tried to unlock oem in developers options. When I try with the phone, it says me: “incorrect code” despite I’m connected to internet with wifi. When I try to unlock oem with the command line, the fastboot command doesn’t work. I’ve got this message:

./fastboot oem unlock
FAILED (remote: ‘unknown command’)
fastboot: error: Command failed

fastboot oem unlock
adb: unknown command oem

I found this topic. It seems that fastboot oem unlock doesn’t exist and we must use fastboot flashing unlock command. What happens if I don’t unlock oem ? USB Debugging option is enabled.


Note: I’m using the last sdk platform from Android for Linux and I’m using Linux Ubuntu system.

You can’t use fastboot flashing unlock if you didn’t toggle OEM Unlocking in the Developer Settings beforehand.

Have you tried generating a new unlock code?:thinking:

If that doesn’t help, please provide a logcat from the moment you input the code :pray:
adb logcat -c && adb logcat > logcat.txt stop the logcat with Ctrl+C after the error messages has shown up.

1 Like

Yes, I generate an unlock code by using my browser to the website with my computer. I generate 2 or 3 codes but each time, the phone says to me: “Processing” and then ‘incorrect code’.

Make sure you only use the latest code you generated, all the old ones are invalidated once you create a new one.

If that doesn’t help a logcat would be really helpful, otherwise just wait for some hours, the unlock server seems to have hiccups sometimes :man_shrugging:

1 Like

Ok. I will try the logcat command. I will give you the result sunday.


I managed to unlock the OEM option. I asked a new unlock code on Fairphone website and I entered the new code on my phone with my wifi connection activated on it. I enabled the option and the unlock oem option is set on enabled now. The topic can be closed. My next step, unlock bootloader with fastboot, install e/os, and lock again the bootloader.



I’d recommend to check if OEM unlock is still enabled before you relock the bootloader - just in case


Ok. I have a question for you. After e/os is installed and the bootloader is lock again, can I disable the OEM unlock option or is it safe to let it on enable ? What happens if I want to restore the original FairphoneOS system (in case I want to use the warranty) ?


You can disable OEM unlock again. Main reason to do so is that in case the device is stolen it’s more difficult for a thief to make best use of it (although your data is always safe, independently of this setting). So I personally would rather not reenable it.
Also because of your second question. If something goes wrong you can always reinstall FPOS independently of the fact if the system still boots or not).

So, if everything is all right, I can disable OEM unlock option like you say. With a custom Rom like e/os, if I disable and want to enable again OEM unlock later, the phone will ask me the unlock code. Do you think the unlock code, given by Fairphone website, will work again under e/os to unlock OEM ?

You can enable OEM unlock on /e/OS without a code.

1 Like

It can be a security flaw, right ?

1 Like

Well, I’m not aware of a reason for a security flaw by that.

I am not very familiar with computer vocabulary:
What is OEM ???

Original Equipment Manufacturer

1 Like

Thank you I guess I don’t need to understand the use of “unlock oem” !

Have a nice time

Just the lock imposed by Fairphone as the OEM, which of course you can disable/unlock

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.