Can't reinstall OS or install google apps after manual 1.8.5 "partition_on_upgrade"


I can’t remember what version i initially had or recall what steps I have taken. The only options the updater gave me was to install 1.6 or 1.8.5 and no partition upgrade. I think I installed 1.8.5 but t hat didn’t give me the option to upgrade the partition, then i probably downgraded to 1.6 and after that i manually installed FP1-Fairphone_OS_v1_8_5_Partition_upgrade_2015-05-12 through recovery from /sdcard.

After this I’m not able to reinstall OS in any way or install google apps.

  • If I install google apps with the updater it looks ok, but after restart it’s not installed.
  • If I try to reinstall OS with the updater it says that it can’t find /cache
  • If I try to reinstall from the recovery mode it won’t find any files in /sdcard
  • If I try to install any of the 3 available 1.8.5 versions with “./adb sideload FP…zip” i get an error:
    Error: Invalid partition setting
    15: ebr2 3d80000:3d00000
    Installation aborted.

###Some info about the partitions:

####root@android:/ # df
Filesystem Size Used Free Blksize
/dev 487M 52K 487M 4096
/mnt/secure 487M 0K 487M 4096
/mnt/asec 487M 0K 487M 4096
/mnt/obb 487M 0K 487M 4096
/system 639M 351M 288M 4096
/data 13G 150M 13G 4096
/cache 452M 8M 444M 4096
/mnt/cd-rom 1M 1M 0K 2048
/protect_f 8M 4M 4M 4096
/protect_s 8M 4M 4M 4096
/mnt/shell/emulated 13G 150M 13G 4096
/storage/sdcard1 29G 401M 29G 32768

####root@android:/ # cat /proc/partitions
major minor #blocks name

7 0 1254 loop0
179 0 15529088 mmcblk0
179 1 1 mmcblk0p1
179 2 10240 mmcblk0p2
179 3 10240 mmcblk0p3
179 4 6144 mmcblk0p4
179 5 665600 mmcblk0p5
179 6 471040 mmcblk0p6
179 7 14325376 mmcblk0p7
179 8 13618816 mmcblk0p8
179 64 2048 mmcblk0boot1
179 32 2048 mmcblk0boot0
179 96 31267840 mmcblk1
179 97 31266816 mmcblk1p1

I fear that the partition upgrade has screwed up your phone since:
a) there seem to have been some faults with the repartition upgrade (a new version was released today), and
b) it was supposed to run after upgrading to 1.8.5, not before.

Although I’m not 100 % sure, I suspect that you have two options:
a) trying the fairly complicated solution described by @daveboschma here:
Google Apps can’t be reinstalled or
b) wait for a fix that the FP developers are working on right now.

1 Like

@kgha is referrin to this update specifically:

Hi @Lurq,

I have also got the invalid partition setting installing from Zip, but using my method everything worked out well. It looks like you’re experienced on command line, so if you feel comfortable playing around you may try out my installation via adb. Please use it at your own risk.

It looks like “screwed up”, but this did not really happen. Indeed, there is an old Recovery image in place, not compatible to the new partition layout, and an outdated signature file which makes GApps not being installable. But luckily this can be worked aorund. :slight_smile:

Thanks everyone for the help! The solution that @Amber recommends is fairly easy and not platform specific. Now I have reinstalled the OS and Gapps!
But these days without access to easy Google contacts and calendar has made me realize how dependant I’ve become to Google… :smile:


I’m glad you got it working now.

Now there is finally an official solution:

This topic is now closed. New replies are no longer allowed.