Can't make calls

My FP1 is only letting me make one or two calls after switching it on, then it won’t put a call through, I can send and receive texts, receive calls and I’ve just been to vodafone and gotten the sim card changed, this hasn’t solved the problem.
Is there some way to fix this? thanks

Wow, I have never heard of a similar issue. Please try to clear the cache of the telephone app (Settings > Apps > All Apps > Telephone > Clear cache).

1 Like

I guess you have already tried the other sim slot?

1 Like

yep, forgot to say that…

It is a bit weird alright, just went into the phone app, the cache is empty, probably because it’s in the 2nd sim slot…

I just checked and it seems that the telephone app doesn’t have a cache (I neither have one). You can delete data since the contacts are stored in the contacts app / storage, so only some call history will be lost.

Just did that, it is still not making calls…restarted it again, was able to make 2 calls, then no more…it does seem really weird!

What exactly happens? Is there an error message? Does the call start, but is aborted at once?

Hm, easiest way to fix this would probably be to install Fairphone OS again. The telephone app will be reset too. The instructions here will also work in our case.

1 Like

… and if your FP1 isn’t running 1.8.7 yet, updating to that one first is worth a try. However, it’s generally always recommendable to cleanly re-install the full operating system from scratch again, as Stefan suggests.

P.S.: Your FP1 doesn’t happen to suffer from general storage and/or memory shortage, does it? :angel:

No, it doesn’t start calling, nothing happens when I press the phone button, there was some error message a few days ago about not being able to make the call but can’t remember exactly and it’s not showing now. Will try re-installing the OS again later on and let you know. Thanks

it is running 1.8.7…no memory shortage

The reset didn’t work, it’s not making any calls now even when I restart it and the message is back, it says: “'Call not sent, no valid number entered.” It says this regardless of whether I type the number in manually or use a stored one.

Are your numbers stored with any symbols (such as “/” or “(” or “+”)? What if you type in a local number and dial it?

no, have tried calling my landline by just typing in the digits, it doesn’t make any difference.

have you tried to sit it in flight mode and co out of flight mode if you are than able to make you 2 calls? May the problem isn’t the phone but your provider. I have a fp2 so the software will diver a bit but there are also the apps “Telefon-/SMS-Speicher(Memory in English)” “SIM-Toolkit” “Dialer” “Cell Broadcast” Which are involved in the call making and so could be linked to your problem. So it could help clearing the cache of these apps too.

It’s not the provider and going in and out of flight mode doesn’t do anything. I assume reinstalling the OS cleared all these caches…

I’ve got the opposite problem, I can make and receive calls, and receive texts, but sending them usually fails, it sits pretending to send for a while (but the progress icon doesn’t animate) and then says Sending failed. I’ve rebooted twice.

Well, as bizarrely as it stopped making calls, it has started making calls again today, so problem seems to have resolved itself, I have no idea why.

But thanks for the help,

1 Like

Maybe your operator did some maintenance in their system and the customer support didn’t even know that you were affected.