English

Can't log into wifi with F2

I can’t log into WiFi with F2. All other devices are fine with this router. I put in network key and then password (wireless key?) and message says ‘password may be incorrect’. Our other F2 connects automatically when we change locations. Have only used 266mb data storage, data saver is off, photo storage is however full.

Hi Galder,
I don’t quite understand. You mean you’re typing in two sequences of characters?
Does this mean that the network isn’t visible when the device scans for available networks, so that you have to enter the SSID of the network manually?

I presume you’ve connected this FP2 to other networks successfully?

One possibility: check that the FP2 is able to use the wifi network’s frequency band. I don’t have a FP2 so I can’t help you there. If you’re still having problems, please post all relevant info: Phone OS, version, anything special or particular about the wifi network’s setup etc.

2 Likes

A password is no key. If you never changed the password of your router/access point, chances are high that it is still the one that is printed on the backside…

Thanks for the input. Graham

Thanks for the help. What I am finding now is that in settings WiFi shows as ‘disconnected’. Touching WiFi leads to an identification of my router saying ‘saved’. Touching that icon leads to a panel offering ‘forget’, ‘cancel’, or ‘connect’. Touching ‘connect’ simply takes one back a step. There is no option to enter a password or anything else.

Which router model do you use? There was a series of Telekom Speedport routers that had a connection issue with Android 9, but this was solved with a router firmware update…

Because it’s already saved. You can choose ‘forget’ and then connect again from scratch.

1 Like

Hi @Galder
“Saved” means including the password that you’ve typed in on a previous occasion, so it won’t ask for another.

I would follow @Incanus ’ advice and “Forget”. After a few seconds, you should then see your router alongside all the other networks that are reachable in your vicinity.

If you don’t see the router then post back with that info and we’ll try and find out why. There’s no point in going further, if you don’t see your router in the list of available networks (unless you’ve taken deliberate steps to make it hidden, which is very unlikely).

If you do see the router, select (touch) the network and type in the password when prompted. This will be the password you’ve used for connecting the other devices that you said, in you first post, connect fine.

Tell us how you get on :slightly_smiling_face:

PS - you didn’t confirm that you’ve connected your FP2 to other networks successfully and recently, so I’m assuming you have. Otherwise, try connecting to a different network if there’s one you can use to test.

1 Like

hey ho same problem again on me. yesterday i had the or an update to os 21.03.0-rel.2 and now kaspersky seems to rule the phone. the surface looks a lot like. any how so i had my wlans saved and it didnt log in and you can not click a button connect you just can cancel what your doing or delete the wlanname. i tryed to log in at a official free wlan at the grocery store but nothing. if you click on the icon you just can turn it off or on. if you just wanna see which wlans are there you have to go into the system.

Hi,

Thanks for the advice. The phone shows all the networks in the vicinity including ours. BUT when I tried to connect to my neighbour’s it would not do so returning immediately to the list of networks. So seems to be the FP2/Android.

Regards,

Graham

Thanks for posting back @Galder .
What happens when you “Forget” your own network and start again? Do you obtain the same result as when you try to connect to the neighbour’s network?

Other info we’ll need : which OS and which version is the phone running? If you’re not sure, open Settings > About phone. You should see “Android version” and “Build number”.
When did the phone last connect successfully to a wifi network and was that your network or some other?

In particular, have you recently updated to Android 9? Or have you made any other changes recently that might be relevant?

1 Like

Hi, When we ‘forget’ on our network it goes back to the listing of networks. The same happens with our neighbour’s network.
It is Android version 7.1.2. Build No. 18.09.2
It is my wife’s phone so I am not sure of the details. It connects to the network through the mobile phone network but she is not certain when it last connected through wifi. We were recently in Kenya for some months and she thinks it was connecting through the wifi and given the speed she had this could have been the case. She has not updated to Android 9 or made any deliberate changes.

Hi @Galder and thanks for the info. I think this makes things a lot clearer :slightly_smiling_face:

As far as I can judge, the problem is simply to make sure you are using the right password when you try to connect to your router’s wifi network.

If you have no record of having changed the password of the router, then it will likely be marked on a label stuck to the back or underside of the router. Otherwise, check your documentation.

It will be a string of letters and / or numbers. In the listing of networks, choose (touch) your router’s network. You should be simply asked to type in the password. Make sure you type it in exactly as it is printed on the label or in your documentation. In particular, it’s important to conform to the UPPER / lower case for the letters (if there are any in the password). In the case of a password printed on a sticker or label**, the characters may be printed in groups (of 2 or 4 for example). If this is the case, do not include the spaces - they are just there to make the string more easy to read!

** The password may also be referred to as a “key” or “PIN”.

For more information see this help page for setting up wifi with Android 7.1.2 following steps 1 - 5. Step 6 probably does not concern you.

@Galder , did you mean by this that you don’t get asked for a password when you choose a network in the list?

That’s right. Sometimes I am not asked for a password - sometimes not. I can then go back by entering ‘forget’. When I do enter the password on the base of the router it returns to the list of nearby networks and appears to make no attempt to connect.

Hi @Galder me again.

OK so probably not a password issue. I’m trying to summarize the details of this case. As I understand it, you have two FP2s. One of them connects automatically to your router’s wifi network and the other one doesn’t: it fails to connect when you type in the password. I find this strange, unless these two phones are running different OS or different versions of Android.
Could you post back with the following info:

  • Android version and Build No. of the other phone (the one that successfully connects automatically to you router’s wifi)?
  • The router make and model.
  • The security / encryption version currently used (WPA, WPA2, WPA/WPA2, …) You’ll be able to find this from one of the other devices that are connected successfully, or from the configuration interface of course.
  • The versions the router is capable of using. See documentation or configuration interface.

It seems there have been issues with certain routers especially when using WPA2. See the following threads. They concern FP2s running versions of Android later than the one you’re using on the phone that fails to connect, and indeed sometimes triggered by the updates, but may be of interest. This is why I also asked for the configuration of the other phone (the one that connects).

FP2 running on build 19.11.2
FP2 after updating to 19.08.01

One other simple thing you can try and that we haven’t mentioned yet : turn off the router, leave it off for 5 mn and turn on again. :upside_down_face:

1 Like

Hi,

I of course switched the router off/on some time ago but I just did it again to make sure.

The Android version on the other identical FP2 is 7.1.2. The Build is 19.11.2

The router is a Technicolour DWAO 120 as far as I can determine.

The info below is taken from my laptop that uses the same router. I assume that Qualcomm Atheros make the Technicolour router.

SSID: …
Protocol: Wi-Fi 4 (802.11n)
Security type: WPA2-Personal
Network band: 2.4 GHz
Network channel: 11
Link speed (Receive/Transmit): 144/144 (Mbps)
Link-local IPv6 address: …
IPv4 address: …
IPv4 DNS servers: …
Manufacturer: Qualcomm Atheros Communications Inc.
Description: Qualcomm Atheros AR5B97 Wireless Network Adapter
Driver version: …
Physical address (MAC): …

Regards,

Graham

Edit by @Alex.A: As suggested by @OldRoutard below, I edited out some personal information.

Hi @Galder and thanks for the info!

The “Qualcomm Atheros AR5B97 Wireless Network Adapter” is the wifi adapter of your lap-top, it has nothing to do with the maker of the router, but you’ve posted all the info I think we need.

I’ve had a look at the router documentation. I suggest you use the method detailed on p. 5, Connecting a Wi‑Fi device using WPS Push Button Configuration (PBC). Using the push button avoids the need to type in a password, as any device can connect during the 2-minute window. You will see from the documentation that the successful registration of the device is signalled by the WPS LED - solid green (hopefully) or blinking red.

So all you have to do, is start “WPS Push Button” on the phone and then push that WPS button on the router. Connection / registration is automatic. “Registration” means that, though the phone doesn’t have the password, the router will recognise the device and let it connect. EDIT : I’ve checked, WPS PBC should be available. See this post for details.

I’ve made a note of the very detailed info you’ve posted. For security reasons I think it would be wise to delete from your post (using the Edit tool, a pencil just below your post) all the details after Link speed, and in particular: SSID, Link-local IPv6 address, and Physical address.

I see two other possible solutions, one of which is suggested by @Alex.A just below: updating the phone to 19.11.2. That would probably be the best.

1 Like

This is an OS version which is nearly three years old and prior to the update that solved many wifi problems (19.11.2). It must have accumulated quite a few bugs. Have you updated the device? It is for me the simplest and most obvious way to solve the problem (just open the updater app and refresh, and install the suggested update). Also, the device won’t receive the upgrade to android 9 if under this build, you will have to update it first.

5 Likes

Have fun while reading:

https://bugtracker.fairphone.com/project/fairphone-android-7/issue/36

2 Likes