Can't install more than a few Apps on my phone

Hey everyone,

I’ve got a problem with my fairphone and am not quite sure if it’s a problem with the phone, with android, or just the way I use the device, but I guess asking more experienced users here is a good start.

What it comes down to is that I can only install very few apps at once. Right now I’ve got Chrome (because the standard browser had a lot of problems with a lot of websites…), Dropbox, QR Droid, a Quiz game, a compass app and Whatsapp. That’s it - theoretically all relatively slim, no big games or anything.
Still, when I try to install a new app from the Playstore it tells me there isn’t enough memory available. When I go to the menu which displays the internal memory, it seems to be about 2/3 full when looking at the graphics, but the text below sais 509MB apps, 95MB cache, 98MB available… although there’s 0.98GB of total space, not sure where the remaining 300 are?!
To solve the problem I installed CleanMaster and moved several apps from the internal space to my SD card, but it didn’t seem to have any effect at all on the problem as I still couldn’t install another app.

I’ve got this problem for quite some time now and previous Fairphone updates didn’t help. This is quite frustrating as a smartphone without the possibility to install apps is somewhat pointless…

Anybody got an idea what could cause the issue and how to solve it?

Any help would be greatly appreciated. :slight_smile:

Thanks in advance,

I believe the solution for you would be to install the partition upgrade (you have an “internal storage” and a “phone storage” atm right?).
First you should do a thorough backup because the partition upgrade erases everything.
How to install depends on your current operation system version (can be found in the upgrader app).


Can’t really add anything to what paulakreuzer said. The good news is your problem is a standard problem that can easily be dealt with, but again as paulakreuzer says, you MUST backup. The partition upgrade is like formatting your computer’s hard drive (to be exact, it’s like formatting two hard drives into one), so the loss of data is not a risk, but a guarantee.


Thanks guys… was hoping there was a solution that does not include formatting the whole thing… if that’s a standard problem however, I’m wondering why I couldn’t find anything about it online? Just these “move your apps to your SD card” kind of solutions. Well maybe I just didn’t google hard enough. Anyway, thanks a lot, I’ll see if that does the job!

That might be because till today there are only 60’000 Fairphones in the world and this storage problem is Fairphone-specific :smile:

Nope. It was the standard Android storage layout. There are posts on this for other vendors from 2013 and earlier, or for mobiles with Android versions of this time. Since Fairphone has an active community you’ll find most recent discussions on this from Fairphone users.


Hey guys, I actually continued using the phone with the broken storage layout for almost a year and today finally tried to tackle the problem. Unfortunately the partition update link you posted contains another link to a guide on how to do the update, but that link is broken. I tried to find the page via google, but it yields the exact same broken link, so I guess the site is just down (this link).

I then found another topic of a user stating that downgrading to Fairphone version 1.6 would solve the problem automatically, so I did that using the Fairphone updater. Storage layout is still broken, but now on top of that I can’t access the Fairphone Updater anymore (instead I always get an error message, “The process has stopped” I believe).

So I guess my only option now would be a hard reset and restart from scratch. But then again I have no idea how to actually install that partition upgrade as the linked site has gone. I tried to google for other guides, but the one linked here is also gone and just leads to a not very helpful support page. This is really unfortunate. :confused: Any help on this issue would, again, be greatly appreciated, and I guess this time I’ll follow the suggestions much sooner than a year after the fact. :smiley:

Thanks a lot!

For this you may find an answer here:

  • Go to your system settings
  • Tap on the Apps icon
  • Go to the ‘All’ tab
  • Search for the ‘Media Storage’ icon & tap on it
  • Tap on the ‘Clear data’ option
1 Like

The storage upgrade removes all data from the phone anyway, so you’d be restarting from scratch even if you didn’t have an issue with downgrading to 1.6.

There’s a tutorial for installing the storage updater under 1.6 here and one for 1.8.7 here. Fairphone seems to have had an issue in the support pages that broke a ton of links…

1 Like

Thank you for the links! I’ve run into more problems though. I tried to figure out which version is really installed now (because who knows if the downgrade actually worked). In the fairphone updater it sais my current version is Fairphone Cherry 1.6. If I go to the advanced mode then and pick Android for Fairphone, it sais my current version is 1.8.7 and presents me the options to install cherry 1.6 or storage upgrader for 1.8.7. So… what’s the current version, 1.6 or 1.8.7? And which version do I install now? Man is this all confusing.

Hmm that’s confusing. It could even be a bug / side effect of the downgrade.
Perhaps it’s going to be easiest to first upgrade to 1.8.7, and then to apply the update - that way there shouldn’t be any confusion about the version… (assuming you want to end up with the latest version at the end of all of this…)

I now successfully reinstalled 1.8.7 and proceeded to follow the instructions by installing the storage upgrade 1.8.7 version. It was downloaded and I selected the phone to reboot. Now for the last 15 or so minutes it just shows a blue screen (the typical Fairphone blue, not a BSOD :D) with no feedback whatsoever what’s going on. Is this to be expected? Does this just take a while and I can simply wait for it to finish? In the instructions it doesn’t say anything about expected waiting periods, and after previous updates the restart process would usually be done in a minute or so, so I’m a bit concerned.

It can take a while, (I don’t remember how long - it’s been ages ago…) Leave it for a bit longer and if it doesn’t proceed try restarting (maybe the battery will need to be taken out). If it doesn’t start properly then issue a reboot command from recovery, there are instructions for that here.

Very important: make sure your phone doesn’t go to stand-by during the update. You can do so by tspping on the screen from time to time.

1 Like

Or do the following:

1 Like

This seems to be a rather important piece of information, shouldn’t this be mentioned somewhere during the update process? :confused: Consequently I didn’t do any of that.

The phone is lying there with unchanged blue screen for over an hour now, and I don’t want to force a restart in case it is actually still working (although I doubt it)…

I had to take out the battery. Restarting does not work. I can’t access the recovery mode either, no matter how long I press volume up + power button, I always just get the blue screen. When I try to start it regularly I can then shut down the phone by holding the power button, when I try to enter recovery mode however I have to take out the battery again as it doesn’t respond to the power button whatsoever. I get the feeling the whole updating process just completely broke the phone. :frowning:

Keep on trying! If you succeed in entering recovery mode, not all hope is lost. You can install Fairphone OS manually.

As a last resort go to this post and continue to XDA’s tutorial on how to flash the Fairphone binaries onto your Fairphone 1.

1 Like

What happens if you restart your phone by volume down + power button?

1 Like

The same as with volume up + power button. Blue screen and I can’t shut it down without taking out the battery.

NOOOOOOOOO not true a wild factory mode appears. :open_mouth:

  • So my fairphone is basically Jesus. Clinically dead for a few hours and now it’s back, the partition upgrade seemingly worked out.

Apparently everything’s cool now. Thanks a lot for your time!