English

Can't install Fairphone open OS after updating to 1.5.1 OS

Hi all,

I just updated my fairphone 2 to 1.5.1 standard OS. My next step was to install the Open OS. However, I got the following error:

Can’t install this package (Tue Jun 14 15:55:46 CEST 2016) over newer build (Wed Jun 29 1:54:03 SGT 2016).
E:Error in /cache/fp_update.zip_
(Status 7)

Do I simply have to wait until the latest open OS is released and if so, how long will that take? In the mean time I suppose I could root OS 1.5.1.

Thanks in advance

Which *.zip file did you download? Here you’ll find the latest build. IMHO it should work with the first linked zip file (under OTA Build switcher). Please be aware that when switching to FP Open OS all your data will be deleted, so make sure to backup your data beforehand. :slight_smile:

Yes, I used “fp2-sibon-16.06.0-ota_from_gms-userdebug.zip” (just double-checked to be sure).

I’m also fully aware of the consequences of flashing a new OS :slight_smile:

Well, I am not happy to hear that. :frowning: But alternatively you could try installing via fastboot (see same link above for the appropriate zip file). Do you know how to do that? (If not, see Method 2 in the Installation Guide or else this helpful wiki post.)

1 Like

Yes, please wait, so you don’t have to downgrade.
16.06 = 1.4.2
The last two FP Open OS versions were released 3-4 days after the corresponding FP OS releases.

2 Likes

I guess you have to wait for Open OS 16.07.0, which presumably is going to be released soon. Open OS 16.06.0 is based on 1.4.2 and that’s why you receive the error message.
In the past, the corresponding Open OS version has been released a couple of days after the Fairphone OS, so it should not take them long anymore (hopefully :slight_smile:)

EDIT: @paulakreuzer was faster, sorry for a duplicate answer :smirk:

2 Likes

Alright, thanks for the help, Juli_R. I tried the fastboot method and it worked! I subconsciously tried to avoid using fastboot because I know from past experience it’s a lot more cumbersome, but your post made me try it anyway.

And thanks for the info on official OS vs. Open source OS, guys. I may have a lower firmware version now, but I’m just glad to be rid of all the google junk and to have a bit more control over my cellphone.

Now back to reinstalling some apps on my squeaky clean phone :slight_smile:

2 Likes

Want to change to Fairphone Open OS but updated to 1.5.1. How can I downgrade to previous version? Want to use my phone from now on (not waiting for Open OS 16.07.).

Thanks in advance.
Nailix

I moved your post here. If you read the posts above you’ll see that besides not being recommended it’s also not that easy to switch to Open OS if it’s a downgrade. So better wait for the next Open OS.

PS: @M_Dammer, I moved your post here too.

I want to move from stock FP 1.5.1 to the latest open source version 16.06 and I get the error above. Is there any way to bypass this version check as it is not an update but will delete anything anyway ? Or a version 16.07 that is actually up to date ?

The last two FP Open OS versions were released 3-4 days after the corresponding FP OS releases.

The 1.5.1 version was released 16 days ago and no sign of an upgrade of the Open OS version. I cannot understand this delay. And I cannot understand any reason why the Open version is always released after the closed one. With the build tools being pretty much the same I would expect a simultaneous release of both versions.

1 Like

Any news on a new version realese of FP Open OS?

No.

But you can always check on http://code.fairphone.com/ for the latest available version.

Ok, thanks.

I’ve checked. I’m stuck in the “not that easy to switch to Open OS if it’s a downgrade”.

You could go back to 1.4.2 stock and than to OS 16.06
>Here how I did it<

If I click, I get fb2-sibon-16.07.0-ota-userdebug.zip

Ouh, yes, that’s what you’re supposed to get.

The first link (the one for switching from GMS - the ‘OTA Build switcher’) should be:
http://storage.googleapis.com/fairphone-updates/fp2-sibon-16.07.0-ota_from_gms-userdebug.zip (it doesn’t show up properly in the post preview - probably a discourse bug)
The fastboot image is here.
I’d personally wait for the release notes before installing…

2 Likes

Hej! Same problem here. Just bought the phone and did a hasty update to 1.51.
Don’t want to wait weeks until I use the phone.
The 16.07 Open Version is not available under the link. A download only has 127 Bytes - So just a dummy created for the new version :(.
A call with the fairphone support informed me, that the update 16.07 should be available this week.
So, I wait and hope the information is correct!
If not, I’ll try the fastboot.

Best regards,
David

1 Like