Can't install Dec 2021 update

Whenever I try to install the December update the progress bar stops at about 85% before it completely disappears and is replaced with “Installation problem”. There’s no other information. I can press “Try again” but it always stops right before it’s finished.

Are you rooted by any chance? :thinking: You will probably have to follow these steps:

Or you can factory reset your phone, that should work to.
If it doesn’t, head on over to:

Where we discussed that before, so far without success. I would really love some more information in that case, so we can get this fixed for others as well :pray:

It was rooted but I’ve actually already reflashed the stock image before trying to update. I just downloaded the Magisk app again and it’s not installed. I also can’t uninstall it via TWRP because the TWRP file manager apparently can’t display the internal storage.

Did you factory reset your phone or did you flash one of the stock boot images.
If you flashed a stock boot image, could you try to flash that to the other slot as well. I still think it’s a possibility the updater tries to patch the other slot and that one is somehow tainted :thinking:

Yeah, the available TWRP doesn’t have access to encryted /data for now, but TWRP has become less and less useful for newer phones anyway, so :man_shrugging:

Just did a factory reset and it still doesn’t work
Flashing the stock image to both slots also doesn’t help

Alright, that disproves that.
Could you get a logcat ($ adb logcat > logcat.txt) please :pray:
Maybe we can find some clues in there to what’s going on :thinking:
I sadly only have access to two already updated phones, so it’s hard for me to reproduce… Unless there’s an update in the next few days. Pixel devices have gotten the new patches a week ago, so here’s hoping :crossed_fingers:

Do I have to do something to prepare that? ADB doesn’t seem to do anything when I do that. It creates the txt file but doesn’t write to it and the command doesn’t end

Ah, I assume you’re on Windows, use:

  • $ adb shell 'logcat > /sdcard/logcat.txt'
  • Try the update and wait for it to fail
  • Press Ctrl+C in the terminal you have adb running
  • $ adb pull /sdcard/logcat.txt

What’s the path for the internal storage? I’m not using an SD card because the phone keeps rejecting them

/sdcard is the path to internal storage, Android does like to keep strange legacy stuff around :smirk:

“The system cannot find the path specified”

Huh, weird, which step? :thinking:
Did you have adb working before? What’s the output of $ adb devices?

Yeah, adb is working fine (phone showing in devices, reboot commands, flashing etc). But when I enter
adb shell ‘logcat > /sdcard/logcat.txt’
it just says “The system cannot find the path specified.”

Strange, well, let’s do it manually then:

$ adb shell
FP4:/ $ logcat > /sdcard/logcat.txt

… and then rest of the steps.

Just amended the title, to add date, as there may well be others. Probably better to add real update title.

That worked

Good point, I’ll keep that in mind

1 Like

The log is cut off before it get’s interesting :thinking:

01-12 15:25:50.116 6527 6527 E ActivityThread: at android.content.ContextWrapper.bindService(

Could you check if your logcat.txt is as well? :pray:

Damn, I should’ve double checked that. Just searched for a fileshare site, I doubt a codeshare site will allow me to upload everything

You can also just attach the file to your post next time.

So, let’s see, first of all, we now have the link to the, that might come in handy :smiley:
And this error here looks promising:

01-12 16:02:00.988  1384  1384 E update_engine: [] Unable to open ECC source partition recovery on slot A, file /dev/block/bootdevice/by-name/recovery_a: Success (0)
01-12 16:02:00.989  1384  1384 E update_engine: [] The hash of the source data on disk for this operation doesn't match the expected value. This could mean that the delta update payload was targeted for another version, or that the source partition was modified after it was installed, for example, by mounting a filesystem.
01-12 16:02:00.990  1384  1384 E update_engine: [] Expected:   sha256|hex = AC800864700E98E449C53A6F9B1BA0097440FFAEB2F2FFE93007442B110BE335
01-12 16:02:00.991  1384  1384 E update_engine: [] Calculated: sha256|hex = 0D15E2429A87C860B3EA29C75D386AB0103A1BEADF106CE6CDC92F01E8187E4C

Did you by any chance flash TWRP to your device? :thinking:

1 Like