Can't install a big app with additional files

I just started setting up my new Fairphone 3+ and I like it quite a lot. But there is one game that I really don’t want to leave behind that I can’t seem to get working.
I can install it but it crashes right after launching. According to the developers support documentation this is likely a problem with my devices OS. Here are some things that might point to the problem:

  • The game is nearly 2GB big and when installing it via the Play Store all of that data seems to be downloaded. After installation the App only uses a little over 200MB. So it seems that additional game data is not saved.
  • Others with a similar problem mention the game has trouble with several User Accounts on one device, but I only have one google account set up.
  • Using a custom ROM might be a problem, what is the FP3+ using by default? I haven’t changed anything there.
  • Installing the game from another service (not Google Play Store) yields the same result.

Any suggestions what else I could try? Could there be some problem with the google services? Could there be a general problem with apps that used additional files?

Thanks in advance and let me know if you need additional info!

Edit: When I watch the installation process I notice that the Playstore even displays an error popup after installation telling me that it failed, suggesting that I should try to restart the phone or empty the playstore cache. None of this helps.

Another Edit: I tried another game which resulted in the same problem. That one was not that big, but still bigger then your average App.

Yet another edit: The problem seems to be the obb files for apps. The phone has trouble saving those files when installing. They are downloaded but not placed in the right path, the corresponding folder is empty. I haven’t founda a solution, but I’m pretty sure that’s the problem.

Welcome to our community forum :slight_smile:

This can be ruled out as the problem because by default, the FP3+ runs a stock Android certified by Google, not a custom ROM.


Are you using a µSD card? As there are reported some problems, when it is used as internal, not mobile storage.


That was my thought as well, it would have fit with the “additional data isn’t saved” problem. But I just did a factory reset without the SD Card. Didn’t help.

1 Like

Solution found

Or rather a workaround. The problem was that google play was unable to save the OBB file to the corresponding folder. When I tried to manually copy that file there from another phone I noticed that I had no write permissions to do so. I found a reddit post suggesting to try Google Files to adjust permissions and copy the file there. That worked, the game now starts.

Sadly it doesn’t solve the underlying issue, the playstore can still now install apps that need additional files (obb files). I hope there is a way to really fix this, otherwise I’ll need to manually get those files from another Phone all the time…


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.