Can't Create 5 GHz Hotspot after Android 12 Update

Another question: If I choose WPA2/WPA3 my old tablet cannot connect. This only works with WPA2.

I thought the transition ode should make it possible to use WPA3 for devices supporting it and use a fallback to WPA2 if needed. Any idea why that is not working this way?

I have it set to WPA2/WPA3 as well and as you can see in the Screenshot above they FP3 showed “WPA/WPA2” . The FP3 is not WPA3 certified and could not connect to it,so it seems rollback works at least sometimes or the issue is your tablet in this case?


It seems that my tablet does not role back when connectiong to the FP4 hotspot. It should be able to do so, as I can use my Fritz.Repeater and/or -Box. I will try after a reboot of the tablet and cleaning stuff. Maybe that helps…

EDIT: Cleaning Cache and rebooting the tablet help. It takes quite some time, but finally it will use WPA2 with the transition mode being active on the FP4 hotspot.

1 Like

Older wifi chips might have various kinds of problems connecting to WPA2/3 transition APs. E.g. my notebook does not even see a wifi advertised with the transition mode…

1 Like

Personally I experienced that the 2.4GHz band worked just fine but my Fairphone 4 wouldn’t let me use 5GHz Band when using the Wifi-Hotspot function.

It wasn’t working in Android 11 and now with the new Android 12 it’s still not working for me. Maybe its a bug that hasn’t been discovered yet but thats my personal experience with Internet tethring / giving wifi hotspot

This has been discovered. That’s why I’ve moved your post here and you can read above.

1 Like

I saw that this issue was added to the wiki below.

It got an :orange_circle:, I personally would give it a :green_circle: since you can still use the phone as a hotspot, right? At least I can. I haven’t checked if 5GHz works fine or not. But since 2.4GHz works, it would make more sense to label it with a :green_circle: But that may be just me. Just my 2 cents and I’ll leave it up to the community to change or leave it as it is.


I have the same problem. With 5ghz option i cant start the wlan hotspot. i dont need it, but its a trueless bug.

The problem is that it actually doesn’t work in cases when you are connected to a 5GHz network. It starts a 5GHz hotspot instead and then silently crashes. I bet most ordinary users won’t figure out what’s wrong.

1 Like

Hi everyone,

I have a brief update to share regarding this issue. Our team confirmed that this behavior is not expected and they’re looking into it. The root cause is still unconfirmed but they have some leads. So far, it looks like a fix will not be ready for the next software update.

I’ll write again when there’s more news.



Is there a self-diagnostic tool on FP4 that would allow seeing which components work and which do not?

My more specific problem is as follows. If I create a Wi-Fi hotspot, it goes without problems for 2.4 GHz Wi-Fi. However, it does not start for 5 GHz.

Recently, I upgraded to Android 12. I had this problem previously on Android 11. A few months ago, after a reboot, the 5 GHz Wi-Fi hotspot would work. Now, soon after the OS update, I noticed that a restart no longer helps. Between the two instances, I did not use the hotspot feature, so I am not sure whether the change is because the hardware problem progressed or because the software works differently.

There is a large range of hardware tests when you dial * # * # 2 8 8 6 # * # *

(I can’t recall right now if there’s a specific test for what you are looking for, but some connectivity tests should be among these.)


Please read above reg A12 and 5Ghz Hotspots


Confirming the problem. After upgrade to Android 12, attempt to activate 5GHz hotspot results in an error shown in the screenshot. This appears if 5GHz preferred is selected for for the AP Band. If 2.4 GHz is selected, the hotspot works.

1 Like

I was very optimistic and tried the Hotspot on 5GHz with FPOS B-048, too. This is still not working. However this was not mentioned in the release notes anyway but I tested it despite that.

I just upgraded my Fairphone 4 from Android 11 to Android 12, the name of the build is FP4.SP21.B.048.20230215, and since then it is impossible for me to create a shared (wifi) access point. I’m using this feature every day, so it is pretty important to me. What happens is that the toggle for access point switches itself off every time I press it. I’m not in economy of energy mode.

I’ve tried everything: restarting the phone, deactivating data, reactivating data, changing wifi name / password, deactivating “automatically deactivate access point if no connected device”, …
The only thing that worked was changing from 5Ghz to 2.4 Ghz. I can live with that, but is weird because there are only 6 networks around me and it was working perfectly fine before the update.


1 Like

Hi and welcome, thats known already with the previous A12 version, I moved your post here, please read above.

1 Like

You have to l disable WiFi first before you can turn on the hotspot, even if you are not connected to a wireless network.

With my Fairphone 4 it even does not work when Wifi is turned off before. Does anyone know when this bug will be fixed ?

5 GHz won’t work at all for the hotspot. But 2.4 GHz should not be a problem.