Can't connect to eduroam (FP2)

Hi everybody,

somehow I can’t connect my new FP2 to the eduroam Wi-Fi network here. I downloaded a root certificate from my university (rootcert.crt) in /sdcard/Download and selected this file in the Advanced Wi-Fi menu > Install certificates. Then I chose everything as described on the university’s help page (EAP method, phase-2 authentication etc) but still get the error message “Authentication problem”. Phone is locked wih PIN, only 1 SIM card, backup to Google disabled.

Thanks for any suggestions!

Eduroam works fine for me. When I wanted to install the certificate, there was even a notification that it was already installed…

However I remember days at my university where eduroam didn’t work at all for anyone, independent of their devices. Have you tried logging in for a longer period now?

eduroam works great for me!
I think it’s a problem of your university.

Oh, you did the installation wrong. You’ll have to save the cert somewhere and then go to the WiFi settings and install it from there. You’ll have to choose that you use the cert for WiFi and then you go to the settings of eduroam and set it there.
Until you do this, you are using it in an unsafe way!


That’s confusing. All I did was to go to the download link and then I got told the certificate was already installed…

Yes, it’s installed (in fact it’s one of Telekoms Root CA-Certs), but not for WiFi. You’ll have to do what I wrote above.

Thanks everybody, I got it solved by calling the help desk. Turns out you do not need to enter a certificate at all. Now it works.

This is simply false.
Unfortunately, I do not have an English source, but this article (German) was just published some weeks ago.

The quintessence is: Without that certificate anyone with a laptop and a WiFi-Module can make your device connect to him and give him your password. Additionally, he then can play “Man in the middle” and read all your internet traffic…


What @retsifp says. Also, DFN (if you are in Germany) and other parties of eduroam do know about this since ages.


If the helpdesk told you otherwise, please inform the admins. This is nothing lightly said, but it is likely that they have given you false advise, and if there are more people who got that advise, they are unsafe. Which, on an university network, is a VERY bad thing.


Thanks for the info! I just read the article and it really sounds bad. In the eduraoam manual of this university they tell you to install the root certificate so they don’t give false advice to everybody. Maybe it was just me calling there for help, and I found it strange they told me I do not need the certificate. But of course I will ask again - don’t want my new FP2 to be hacked!! (but this will have to wait a couple of days until things run normal here - Alaaaf!)

1 Like

Do these issues also apply to the local wifi of my university? We have two SSIDs here, one called eduroam and one with the name of my university (I think that’s the way most universities handle it?!).

You’ll have to ask your university, we cannot tell you this. At my university, there is only one WiFi, eduroam.

I also had an issue with eduroam. I used it without certificate, but setting up my new FP2 I wanted to do everything the right way. My problem was, that the installation of the certificate did not work with Firefox. That was also stated in the instructions from my university. Trying with Firefox, I got a prompt, that the certificate is already installed. But this applies only for the browser, but not the wifi connection. I re-activated Chrome and was able to install the certificate and label it with a name.

I have downloaded these two certs om my FP2 but i don´t understand how I can get those to wi-fi. I don´t know how to save with this phone.

First of all, you’ll have to save them to your phone. If your Browser just tries to install them and doesn’t give an option to save them to your device, you’ll have to connect your phone to the PC and transfer it via usb, which is what I did. Just save it to the “Download”-Folder, so you’ll find them later easily.

Then you go to the advanced WLAN-Settings (“Erweitert” in German):

There, you can install your certificate (“Zertifikate installieren”):

After that, select your file from the storage, set a name and select that it’s for WLAN:

Since I’m not connected to eduroam right now, I can’t show you the last step, but it’s quite easy: Long tap your network and select “Edit network” or something like that. Then select “certificate”, where your freshly installed cert should appear.

1 Like

I set up eduroam a while ago on my FP2, installed the certificate and it shows up in the network settings and so on. Now through this threat I wanted to check something and noticed, that the certificate was not selected anymore. Of course I immediately changed the setting again and saved it, only to find, that each time I select the certificate and press save, it just doesn’t do it. As soon as I get back to the settings, no certificate is selected.
I reinstalled the cretificate under a different name to crosscheck and even deleted the network and set it up again, but nothing changes. I was convinced, that I was using the root-ca2 for the last 5 weeks, but apparently I wasn’t. This shocked me a bit. Anyone got any idea on why that could be the case?

Thanks and best regards,


1 Like

I also can’t change the certificate. I have to delete and re-set the network up again to change it. But for that, you have to be at a eduroam place (not at home or elsewhere).

Also, installing the root certificate is not easy. You can’t install it from the browser, but you have to select “Install certificates from SD card” in the security settings after you have downloaded it.

At least, I got eduroam working with a certificate.