Can't connect FP2 to any Computer

Hi there, unfortunately my FF2 will not connect to any computer. I’ve tried two different cables, three different computers with two different operating systems (Win 7 and Win 10). Whenever I connect the phone, the computer says “USB device not recognized”. Even the battery does not charge. Any ideas what could be wrong here?

When you connect do you get a notification on the phone? (Slide down from the top to open the notification panel).

Tap the notification and tick MTP or untick all of the options. One of those two should work.

I also had some trouble at first. What worked was Pauls tipp. With this I could use the USB tethering and also browse the internal memory of the phone, charging also works fine. ADB however is still not working for me, despite some users apparently having success with the universal drivers.
But if your phone is not even charging I believe it might be a different issue…

No, there’s no notification at all on the phone. :frowning:

Yeah then I also guess you’ll need another cable.

Well, I’ve tried two different cables already, one of which brand new… To me it rather seems as if the socket on the phone might be defective.

Two cables is not that much, even if one is brand new.
But sure it could be a defective phone too.

Are you able to charge the phone when connecting the USB cable to a power adapter? If that works, then at least the connector on the phone should be ok. The fact that your computer does recognize that a device is connected (even though it doesnt know what t do with it) suggests, that at least some kind of information is exchanged between the devices…

Well, since your computers say, device not found, there must be some connection between the two devices.

I also had troubles to connect to a Windows computer that somehow solved itself (see here).

My phone was detected by my computer at work (Windows 7) and I could copy files to internal storage and SD card perfectly fine. At home (Windows 10), MTP does not work (phone does not show up on the file explorer). It shows up in the device manager, though (“Android. There are no compatible drivers for this device”). I’ll have to look into ADB drivers in more detail.

I haven’t tried them myself yet, but in this posting they’re talking about drivers downloaded directly from Qualcomm. Maybe there are Windows 10 drivers as well.