English

Can't choose preferd network. Only 2G with (only one SIM Card)

Hi all,

I recently upgrade my phone to Android 7.1.2 and, after 2 days running quite smoothly, yesterday my phone switched to 2G and I don’t have any chance to select 3g nor 4G. The “prefered network” option is in grey color and I cannot do anything to try to use better connexion.
I’m only using one SIM card (I know that is is a common issue when using 2 SIM cards).
I tried to reboot, I tried to use the othe SIM slot, I tried to use another operator, I enabled disabled the network, etc…

What else can I do? can it be a SIM problem? anyway to make sure that it’s a SIM before going to the shop and order another one? (it costs 5 or 10€ and I don’t want to spend that money if it’s not going to fix the problem).

Thanks,
Arnau

1 Like

This appears to be bug tracker issue #50. There is a workaround listed there, and Fairphone appear to be working on it.

6 Likes

Thanks! that was fast.

The workaround worked. (I don’t know why I did not try to reset the network setting :frowning: ).

Thanks,
Arnau

2 Likes

Hellorrr,
Iḿ also having many problems with my connection. I have to SIM card and I have problems with the first (Mocistar) I thought it was the 4G connection when I was using wifi at the same time… People call me and they don’t reach me, afterwards I receive sms saying I was disconected when I wasn’t… I hope I am also under the issue #50 spell…

Hi,

I’m having similar problems. I just opened a new topic for that one.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.