Can't cancel alarm - even reboot doesn't fix

This morning my alarm sounded, but when I went to turn it off the screen hadn’t come on so I couldn’t turn it off. I held down the power button until the phone restarted, and when it came back to life I still had a black screen with the alarm sounding (the screen is working as I watched the bootscreen sequence). I tried removing the battery too, and again when I restarted the alarm was going.

Any ideas? Looks like I’ll have to do a factory reset just to be able to use my phone because I can’t get the phone to do anything except vibrate and beep in my hand. (It did, in fairness, wake me up pretty effectively as I tried to work out what the hell was going on at 0530 this morning!)

1 Like

Update: After leaving the battery out for a couple of hours everything was working when I switched back on. I’m glad I didn’t have to reset the device, hopefully the problem won’t happen again.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.