Can't access internet without wifi

When i am out of reach of any wifi spot i trust, I can’t connect to internet
I have checkef with 1st answer from Lidwien on this topic : I can’t enable data - no 3G!
my settings seems OK ( APN SFR webphone enabled) but if i shut down the wifi, I have no internet connection / no e-mail
This is lasting since 3 days so becomming long, any help is welcome
Best regat regards

Normally, these problems are related to incorrect APN settings. So I’d suggest you compare the settings of your APN “SFR webphone” and the ones you find on the web pages or in the forum of your provider.
Maybe this topic can also be helpful for you:

Thanks Irina for your response
Unfortunately it still doen’t work
I have copied the data enclosed here in the relevant fields, restarted, left no spaces APN type field as suggested in the post you mentionned, rebooted but still doens’t work. Any explanation / solution ? Best regards

In one thread (can’t find it now) someone posted, he had to create a new apn, but modifying the original alone didn’t work.
So maybe you could try as well to create a new one with your right settings.

1 Like

rebooting after I have tried to do so
Any clue why there are less parameters in the SFR information than in fairphone fields ?

Still out of connection after reboot …


Deleting the old APN and creating a new one did the trick for me as well, when I had some connection problems. So it’s always worth a try.

Other people had problems with the APN settings that their providers suggested, so doing a web search and especially having a look at the search results in the forums of other phone manufactures and play around with the different suggestions can be helpful as well.

But just in order to make sure its not a hardware or SIM card defect, try your SIM in another phone and/or another SIM in your FP2.


Thank you Irina, SIMS seems to be working fine on my old Iphone so will try search elsewere for sfr parameters

Ok fairphone does not recognise my sim card anymore
I don’t have any other sim to test,
Trying in slot 2

Ok i suspect a hardware problem
SIM card in slot 1 or 2 is not recognized by fairphone

But can you make/recieve calls and/or send/receive SMS?

card is physically in the slot, but system considers there are none : no pin key upon reboot

I just read that you tried it in an iPhone. As far as I know, iPhones need nano SIM cards but the FP2 micro SIM. Do you use it with an adapter?

it is my old iphone 4S it worked correctly with micro sim I didn’t change my sim cardn when switching to fp2 and fp2 worked ok more than 1 month

Hi there, does anyone have an answer ?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.