Cannot update although "stay awake" is ticked

Well, after the new update was released (may 19th) my phone requested to do just this. I did what needed to be done in order to update but it kept asking me repeatedly to update (still does)! So far I’ve done the whole updating process (including installing the google apps again - and again and again) about 5 times. By now I’m just really unnerved because I’ve had similar problems in the past, which I’ve been able to take care of though after updating about 3 times (same update).

Help please.
Thank you! (:

Go to Settings > Developer options and check “stay awake”. Plug in your phone and try updating again.
This way it should work. :smile:

Tried that just now; didn’t work… just keeps asking me to update :weary:

  • screen has been on the whole time before without checking it under “developer options”

This is a really old version of the updater it seems. You should have gotten the new updater app first.

Could you please tell us which OS version you are using now? And by “the whole updating” process, what exactly do you mean by that? And one more question: Do you get the prompt for superuser rights?

1 Like

Sorry but I don’t know anything about a new updater app, I’ve always used the same one.
My upgrading process: go to fair phone update app, klick update, follow next instructions; finishing with: install google apps again, grant superuser & reboot.
Yes I get the prompt. It says “Android 4.2.2”

If you open the updater app (not by clicking the notification but by finding it in “all apps”) it should tell you your current OS version.

Normally you should be required to reboot during the process.

Android 4.2.2 is the same version we all have, more interesting is the version of Fairphone OS you have. It should be 1.8.5. The procedure should be as follows: The Updater should ask for Superuser right directly when installing and then reboot. Only after that, you should have to update Google Apps. During the reboot, you should see a progress bar.

Do you use the Updater or the Widget to install Google Apps?

Could you please check the Superuser rights for the Fairphone Updater? Follow this guide:

I changed the title, to better reflect the content of the topic! :wink:

I’m really ashamed that I know so little, so thank you for your patience.

  1. The request to reboot only came after I had to reinstall the google apps.
  2. I don’t know where to find the information about the fair phone OS.
  3. I’ve always reinstalled the apps with the Widget.
  4. I’ve always granted superuser rights.
    I can see the animation of the Android-robot with the progress bar after the request to update (without rebooting or granting superuser access) and then again after I’m told to reinstall the google apps and to reboot.

Thanks again!

Here is an article on how to check, which version of Fairphone OS you are using.

Starting from 1.8.5, there is no longer a Google Apps widget. If you are on 1.8.5 already, you will be able to install Google Apps inside of the Fairphone Updater.

There is no reason to be ashamed. I might have been unclear about rebooting: The phone should reboot itself after the installation (the robot lying on it’s back), so it seems that this is actually happening. Check you Fairphone using the link provided by @paulakreuzer, then check the version of the Fairphone Updater ( go to Settings -> Apps -> swipe right to “All” -> Tap Fairphone Updater) and tell us the version.

When opening the Fairphone updater like paulakreuzer said, it doesn’t say anything about my OS. It just reads “Fairphone Updater - Release Notes: Release Notes: For the full list of changes, please visit”. But I can’t find anything under “support” which would help with downloading the new updater…
And now my google apps don’t work anymore (“app isn’t installed”) but: the widget says they are.
The step by step instruction from support isn’t clear either because it doesn’t state where I could get the new updater so that the update or anything else will work! :angry:
I just need a step by step instruction on how to get the new updater and then I’m able to do the rest by myself…

If you open the updater app again and click “cancel” you should see your current OS version. If not then long tap the home button to get to your recent apps, long tap the fairphone updater and tap “App info”. There it should say “version xx (FP 1.x.x)”.

Here is the interactive tutorial on how to install the pre-update (=new updater app). If you don’t have the pre-update available in your updater app I’d suggest you try a manual update.

Well after I tried to install the pre-update what felt like the thousandth time, it somehow magically worked and I’m now in possession of the new updater.
Now, everything works like it should, but no thanks to “support” because they really werent’t clear what the update was about or why it didn’t work…
I’ve tried to get this update since the release date.

But thank you, everything’s fine now.

Best regards,