Cannot store or delete any images on my Fairphone 2 anymore

I have a Fairphone 2 running Fairphone OS 18.01.1 (I tried updating to 18.04.1 several time but I never got it to not work).

Up until last Friday I could use the camera and store photos on my phone. I have a Sandisk 64GB SD card installed and configured such, that the memory is “shared”, i. e. together with the built in storage it appears as one big RAM section of which 15.76GB appears as used and 58.48GB are still available. The whole memory section is being marked as “Interner Speicher”. For no apparent reason - I did not change anything “major” on the phone, apart from installing a “DonkeyBike” app and de-installing it again after a while - I can no longer take pictures, view/download images from WhatsApp, store screensnaps from my phone or delete Images from my “internal storage”. I tried “ejecting” the SD card and re-installing it again, I rebooted several times, but nothing helped. HELP - what can I do?!?

If you go to settings > storage > internal storage > explore, Android’s internal file manager opens. Can you make changes when you use that?

This may tell us whether the issue is with your file system or with the applications you’re using to access that file system.

1 Like

Unfortunately I cannot take screenshots any more so I will have to tell you what I get under “settings -> storage”: On my Fairphone the Settings start with a “Wireless & networks” section, then “Device” and there I can choose “Storage & USB”. Under that I find:
"Device storage

27.46 GB
Total used of 83.96 GB

Internal storage
11.71 GB used of 25.48 GB

SD-Karte von SanDisk
15.76 GB used of 58.48 GB"

I can click on either of these two sections and then get (for “Internal storage”):

"11.69 GB
Used of 25.48 GB

Carsten (in green, this is my user name)
11.31 GB

Other users (green again)
75.76 MB
Cached data
435 MB"

The only menu option I get at this point would be “Migrate data” which I would not like to do. When I click on “Apps” below “Carsten” I get a listing of all my installed apps and their storage usage. The biggest one being “Google Play Music” with 3.85 GB. I clicked on one of the others and was able to delete the app-related data there with “Clear Data” and “Clear Cache”.

I don’t know where to find the explore option you mentioned.

I also tested storing a text file into a folder I had created myself a while ago. Into the same folder I have created and edited many other files before and this also does not work anymore! So, to me it looks as if the file system is blocking me from writing/changing/deleting anything there.

When I had such issues in Android, a full, clean reinstall always solved it. Had to do this for my partner the other day. Make sure you do have backups!

If the filesystem is damaged the system also sets it to read-only.

But as the sd card is used as internal memory in one block it’s not so easy to separate it. I am not quite sure how to check the internal filesystem (without rooting the device) and how it can be performed to separate the added sd card from the system again to remove it to get it re-formated and checked in a usual computer, maybe even replaced if faulty.
Maybe someone else here knows how to get it done. A full clean reinstall may help, but this will not assure the sd card being undamaged.

Same here, Android file systems are unwieldy beasts.

Something’s that worked for me in the past for buggy SD cards is cleaning the brass contacts with some alcohol and a cotton bud - it very likely won’t help you with this issue, but you never know.

Hi everybody,
Thanks for your help and good advice. It turns out that I my case the SanDisk storage card was the culprit. I saved all my data first on my laptop, then split the memory again and told the phone to „forget“ about the memory extension. This and a complete flash of the operating system from a downloaded version from the fairphone site solved the issue. I can now use all functions and store files and photos again.

When I tried to reformat the memory card I was told repeatedly that the card was not formattable. So, that kind of clears the mystery.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.