Cannot install microG Services Core

I recently switched to Fairphone Open, and i would like to install microG to fake google services.
But everytime I try to install it (from f-droid, after turning off f-droid repo because of the signature problem, or via the apk on their website) it says “The installation failed due to an unknown reason” (or something like that, translated to English).
After that I saw that I installed the Xposed module Fake Gapps (which i hadn’t done earlier) and tried again for the same result.
I also tried both 0.2.4 and 0.2.3 (each from their repo on f-droid AND from the apk on the website)

I found no one with the same problem on the Internet, i hope someone can help.
Thanks in advance, I hope my topic is clear enough.

Hi Amaury,

which package have you tried to install?
You need “µg UnifiedNlp (no GAPPS)” - at least, that’s what worked for me :slight_smile:

Also, I’m not sure what you mean by “signature problem” in f-droid. I don’t see any errors or warnings regarding f-droid and signatures.

What I mean by “signature problem” is :
2 apps have the same signature : microG Services core (from mircoG repo) and µg UnifiedNlp (no GAPPS) (from f-droid repo). So when both f-droid and microG repo are active, i see only µg UnifiedNlp (no GAPPS).
I just figured out that clicking µg UnifiedNlp (no GAPPS) with both f-droid and microG repos on is the same as clicking microG Services core with only microG repo on (it doesn’t appear if f-droid repo is active).

So what I did was (I’m almost sure) the same as clicking µg UnifiedNlp (no GAPPS) as you did. Because both clicking µg UnifiedNlp (no GAPPS) (with both f-droid and microG repos active) and clicking microG Services core (with only microG repo active) is for installing the actual microG Services core. It’s not very clear but it’s what I understood from this topic.
Moreover, when I try to install µg UnifiedNlp (no GAPPS) (the real one from f-droid repo, without microG repo active. A thing for GPS and localization I think) it produces the same error.

EDIT to be more clear :
It’s the good thing that I’m trying to install, the “f-droid signature thing” is not very important here. What I did actually is as simple as “installing the right thing from f-droid”, but that doesn’t work “due to an unknown reason”.

Check out this topic (Step 5.5) for a full guide to installing microg.
First uninstall all microg apps you previously installed, reboot and then do it in that order. If you still have a problem installing the service core i can recommend the XPosed module XInstaller, which helps bypass almost any install error.

1 Like

Uninstall any microG app you have and install them from the web if you have troubles. Later, F-Droid will update them without problems.

Thank you very much, I had previously installed microG for OGYoutube and I didn’t know that I had to uninstall it.
But now I can’t use OGYoutube for i cannot have both microG for OGYoutube and microG Services Core apparently.
And in addition my microG Services Core seem not to work (applications still tell me that I don’t have GMS).

Thank you still for the help, I feel that I’m getting closer :slight_smile:

microg is not GMS. Microg can trick some apps to believe you have Google installed, but some apps go through greater lengths to make sure your system is not modified. Check the link I posted above for a full step by step guide that should work for any app.

@Amaury @paulakreuzer
It isn’t always the case, sometime the apps need both microG Services Core and PlayStore (or a replacement) to correctly detect GMS.
Some apps needs also “microG Services Framework Proxy”.

Hi, do I have to do any of the steps before 5.5 in order to get microg working? I just tried from 5.5 onwards and the ‘System Spoofs Signature’ and ‘Play Services (GmsCore) has correct signature’ aren’t checked under Self-Check after rebooting.

You have two options to signature spoof. With Xposed (Level 4) or with Tingle (Level 5 1a).

Hi, I got the signature spoofing to work by using the Tingle option (Level 5 1a) with the help of a friend who’s an android app developer. However, I’ve just updated from 16.12 to 17.02 and the Self-Check is showing that the ‘System spoofs signature’ and ‘Play Services (GmsCore) has correct signature’ are no longer checked, which means I can’t use some apps now.

Will this always happen with OpenOS updates and what would you recommend I do from now on?


Yes this will happen with every update.
You have two options:

  • Get your friend to teach you how to re-apply Tingle yourself.
  • Use the Xposed Module “FakeGAPPS” instead (Level 4 - microg) in which case you’ll just have to flash the Xposed .zip after every update.
1 Like

A post was split to a new topic: Can’t log in to Google with microg