Cannot install apps through repositories (problem already came and went once) *SOLVED*


Hi all,

Thought I would split my 2 issues into separate posts as I don’t think they’re related - the other one being about uninstalling OpenWNN Japanese input.

I installed F-droid. Originally I think I had a problem with downloading it through the phone so I downloaded it to pc and sent it over via bluetooth. My internet connection is slow but not critical, with a little patience I can do everything I want online.

Initially I would browse through the repo, and download and install apps I was interested in (such as Torch and Open Camera, listed here:


At some point I encountered a problem: I would tap “install”, and at the moment I lifter my finger from the screen (tested this by holding it in place for longer times) there would be an instant where the line that shows progress would appear, with the “x” that you tap on when you want to cancel a download next to it. Immediately after these would disappear and a message would appear simply stating “not installed” and then fade away.

This problem disappeared after a while, I don’t know when, and then has recently reappeared, and I can’t download anything anymore.

  • I’ve already tried playing with the screen brightness, setting it to auto, max, and min, and nothing has changed. I am not using flux or any app that affects the brightness yet - wasn’t able to download it.
  • I have a firewall which I’ve activated, deactivated, created special rules… No change. I’ve gone online using the browser and it works fine, both on Wifi and data.



Can you check if the option ‘Unknown sources’ is ticked?
Go to Settings,
go to Security,
swipe the sreen a litte up and then you will see the option 'Unknown sources’
you have to tick it to allow installation of apps from unknown sources.

Thanks for the quick reply @Lidwien - Unknown Sources is ticked.

This happend to me when I tried to install WaveUp through F-Droid. Later I noticed that the icon of WaveUp in the F-Droid list wasn’t showing the normal app picture.
I would suggest that you remove the app F-Droid.
Is it possible with the browser on the phone to go the website of F-Droid and download F-Droid from it directly on your phone? And check then in the app F-Droid if there are updates before anything else.


Thanks @Lidwien! I followed your instructions and it worked: remove F-droid, browse to the site, download. Not sure how to check for updates so looked at the version number (same), installed it, and now I can download apps again. Thanks!

(Also checked if I can now uninstall OpenWnn but still no).

If you open the app F-Droid, then you see three options:
Available, Installed and Updates

1 Like

Ah yes, OK. Luckily nothing to update there. Thanks :slight_smile: