Cannot connect to hidden WiFi networks

I would like to confirm with other FP4 owners that connecting to a hidden WiFi network doesn’t work. I’ve switched the same WiFi network to public, then it connects. So it definitely goes wrong when it’s hidden.

1 Like

I can’t confirm that, switching the WiFi network to hidden works fine for me on stock FPOS (after a short reconnect period).
That’s on 5 Ghz, haven’t checked 2.4 :thinking:

I just tried with a different AP, there it does work. Strange. But it’s a good sign it’s not reproducible, then it’s most likely not a bug of the FP4 but probably that AP.

1 Like

I can confirm that the Fairphone 4 does indeed not connect to some hidden SSID WiFi networks, haven’t had the chance yet to try another WiFi, but to both the 2.4 Ghz and the 5 Ghz network of my Asus RT-AC85P WiFi router, the brand new and fully updated stock FairphoneOS device does not connect, until I switch the SSIDs to visible, then it works for both.

Might try to set up another WiFi router later, as far as I can tell by reading the previous posts, it does seem to work for some, for others it doesn’t.

Anyhow, this should definitely be fixed, please! Every device I have in this house, mostly all kinds of Apple devices, work just fine on these two WiFi networks, and also my trusty old CAT S41 Android phone, which is running Android 8, has no issues connecting to any of the WiFi networks while the SSIDs are set to be hidden… :man_shrugging:

Therefore, I think there is still something going on with the Fairphone device and/or FairphoneOS here. :grimacing:

1 Like

Please #contactsupport and refer to this topic. Since it works for me I cannot troubleshoot with support.

1 Like

I’ve connected my FP4 to a hidden Wifi with WPA2 Personal on Ubiquiti APs without a problem.

1 Like