English

Can you feel it coming OTA tonight? - THIS UPDATE IS NOT OFFICIAL!

Hi,

I have upgraded to Fairphone OS 17.04.3 from Fairphone OS 1.13.0 via Fairphone OS 17.04.1 which was always mandatory as per OTA update multiple times, with and without encryption of Fairphone OS 1.13.0.

While the update to Fairphone OS 17.04.3 never failed, I had one time an issue upgrading to Fairphone OS 17.04.1. The phone rebooted with one retry in boot loader normally in Fairphone OS 1.13.0. A second time using OTA update worked out well.

I would assume it is a timing issue rather than specific to encryption setup. Would you fear to try out a second, or for @Martin_Anderseck a third time?

Alex

Updating the fairphone2 updater app (via manual check for fairphone offerings at google play store and updating the updater app there) from within still android 5 then it starts showing the fairphone 17.04.03 update, all right. It upgraded to android 6 then. Via reboot, then four blue dots animation during bootup for a while, then apps optimisation then it was finally at the lock screen. Update via WiFi.

Whole fairphone2 became kind of hot after the upgraded succeeded but then eventually cooled down again. I miss the Android 5 lock screen though pretty severely :frowning: Too bad.

I’m not 100% certain any more, but I believe, I’ve had it “optimizing” once two times. It finished fine afterwards, but at some later boot, it started optimizing again two apps (for which it doesn’t give more details). But I have also installed a few (maybe just two) apps in between.

I just wondered why the particular optimization is performed at a later boot. Maybe has to do with some new Java Compiler in Android 6 (I really forgot if it came into production version, Google tried out a lot.)?

I could imagine that it doesn’t finish “optimizing” all apps in one row, maybe it needs several runs to finish all of them. But if “Y” is always the same high number, then I have no clue about reasons.

After the update my Google Play Store app states that the “device certification status” is:
“not certified”

Anyone else here with the same problem?
You can check by opening the Google Play Store app and go to settings, its there at the bottom.

l’m a little bit confused. Is this the official Update to Android 6 or is it a mistake? I really want to click that button. Has anyone updated without facing problems afterwards?

I added bringing back the old FP specific features as a feature request.

We don’t think this is an official update. It appears to be the beta version still and shouldn’t be released generally. So i wouldn’t recommend anyone else updating right now. Word is that it won’t be for another week or so until Google have green lighted the official release

Yes, it really seems this update (to the updater app) was released to the play store before the update to the OS was actually approved by G%§$e.

The update was thoroughly beta tested and yes - has been successfully installed many times, but it still doesn’t have the official go ahead from G%§$e. So if you are afraid better wait.

Hmm, I would be surprised, as there is one critical and one important bug in bugtracker, which might probably resolved before release or found to be not critical enough. And there is already a new update in pipeline, so I don’t think that 17.04.3 would be the first release version.

@Jens_Fischer: Practically I believe it was accidentally visible?!? On my Android 5.1 mobile I also don’t see this update.

3 Likes

Euhm okay now I am confused. People who “manually” updated the updater and then went for this Android6 (pre)release or unofficial, how will we advance to the actual real official Android6 for FP2? I didnt want to mess up my phone and I didnt plan or intend to go for a beta or half baked software. Hope this is not a dead end for us accidentally early adopters or us jumping the gun. Thanks.

I really hope Fairphone either pulls the new updater app from the Google Play Store or changes something else before half of the community gets this beta update.

1 Like

I don’t think it will cause you any trouble

The had been an update to the updater app on 31st march to prepare it for the release. It might be a bug there

The update worked fine without any* problems for me (regular Fairphone install without any mods).
It does feel more responsive.

*Problems:

  • Had to install a new SMS app, which was already announced (tried QKSMS, seems fine)
  • All my contacts and calendar infos are stored in my outlook.com exchange active sync account. When I now add this (as I did under Android 5) via “Exchange”, only the e-mails get synced (afterwards, it shows up as an IMAP account in the accounts list - this explains why only the mails are synced). I currently cannot access my contacts or calendar.
  • Problem solved here: Outlook.com exchange active sync not working

The third try was finally successful. I’m writing this now from my updated FP.
Looks okay, I only dislike that I will have to format my SD card to be able to use it again but that’s probably a one time issue. I’m looking forward to a statement from Fairphone about how official this update is really :wink:

3 Likes

Hmm, I have updated the phone with an SD card I already used before. I have had a number of OS installed on it, and I didn’t have to format it in order to use. I guess it has to do with its size and the filesystem it used.

I have heard formatting demands of Android for other phones from other people, but when they ignored the request, everything ran well without formatting and they could further access the SD card as well as continue writing on it without problems. AFAIK it had to do with license issues for a certain file system.

1 Like

That’s​ a good point since it’s a 64 GB card that is formatted as FAT32 which doesn’t seem to be absolutely usual. But it used to work before. Anyway, I’ll save the data from the card using a card reader and let the phone do what it thinks it needs to do since currently I cannot access any data on that card at all.

The “Y” number in the first run was 87 (in my case) but after popping the battery, it dropped to 50 (okay fine the other 37 were done already I guess) but it started looping again and now it’s “optimizing” 97 apps for the third time. In between optimizations the “change is your hands” animation appears and the brightness goes up and down for a while.

1 Like

After The update and reboot an error is shown. I am able to reboot and it’s still 1.13.0. tried again with same result.

I moved your post here as you don’t describe a bootloop.
Be aware that the release of the update yesterday was unintentional - so maybe it’s better that way.

3 Likes

Official Update to 17.04.8 worked fine last night.