Can you disable google searchbar on FP4?

Huh, weird, the device I tried it on is still using the search engine I selected :thinking:
What’s the output of $ adb shell settings get secure selected_search_engine?

It’s not about search engine, it’s about the browser unfortunately :frowning:

Really ? Does this module prevent the micro-second redraw thing when going back to homescreen from other apps to happen ?

Edit1: Just tried it. Wonderful, thanks ! Somehow, it seems that when changing lawnchair settings the recent slide gesture gets broken and I have to disable/enable gesture from system settings to get it back, you get this behaviour too ?

Edit2: seems like Lawnchair 12 alpha 4 is also compatible, so everything is going perfectly fine in the best of the worlds :smiley:

I disabled Chrome. It opens Firefox for everything (as far as I can tell).

I already reset the setting. But I think it happened because I opened the Google widget app.

I haven’t had to reenable gestures when changing Lawnchair settings, strange :thinking:
But I’m also using the Fullscreen Immersive Gestures module, so my setup is probably not comparable.

1 Like

Interesting, I can’t reproduce this, even after opening every Google app on that phone. Did you open the Google widget before the reboot, maybe it claimed that spot in settings before the search selector ever came up…
Maybe the data for should be purged beforehand just for good measure :thinking:

It was already rebooted. Maybe I triggered something special. But it’s not great Google is so eager to take back the spot. It’s not a surprise either of course.

Everytime I exchange a few comments on this forum with you I discover something fantastic… Thank you so much, I had no idea such module existed, this is perfect ! At some point I’ll have to ask you to dump your entire list of tweaks and magisk modules :smiley:


I’m still trying to reproduce it, no luck so far… :thinking:
If it happens again, it would be immensely helpful if you could post the output of $ adb shell settings list secure | grep search_ to see if it actually changed the search provider or Google is doing something different altogether. :pray:

Nope, we can’t. Anyway, I suggest you to try the all new Nova Launcher: it is based on AOSP launcher. I’ve been searching for soo long the best launcher which gives the closest experience to the stock one, and here it is.

It was this option in the Google app. I tapped it because I was interested in what it did. I was still hungover I guess. Expected behavior. But it sucks that there is no interactive way to switch back to DDG. It’s basically a one way street.

1 Like

Nova Launcher is not open-source, right? Quickstep is and allows you to change it to e.g. DDG, it’s also super stable. Something I haven’t experienced yet with LawnChair. Nova is not an option for me since it’s closed-source.

1 Like

Yes, you’re right, Nova is closed like Fairphone OS and other things … I think that if there are no better open source alternatives, we should take that. It gives the possibility to remove the search bar and it is smooth as a rocket, what’s more?

Yeah, that’s it :tada:, that doesn’t change the whole system to Google, but it changes selected_search_engine_aga= to and that apparently means it get’s used for the quick search widget (not default search engine or Chrome though) :+1:

Edit: Interestingly enough, the DDG app doesn’t have the power to do that (or I couldn’t find it)


If I apply this way of thinking, which makes sense, I would be rocking a Pixel phone :stuck_out_tongue: Pixels have open source images, just some added Google magic that make things work smarter and better. Fairphone uses AOSP. Their kernel and some components are open-source. It’s not as open as the Pixel ROMs, but you balance it of course with the eco and social responsible mission of FP.

The search bar doesn’t bother me much, it’s also great to find things quickly on the phone itself. But we should indeed use what works, balanced with what we value on top of that.

1 Like

Hi @Stanzi !
If I understand well, after removing a lot a packages you managed to delete the searchbar while keeping the default launcher, is it correct? So one could play at removing one-by-one each package on your list until he found out the correct one?


1 Like

I’ve uninstalled the package and I can confirm that it is the search bar.

The downside of this is that it replaces the Google search bar with some useless button roughly the same size as the search bar has been before:

(Screenshot taken from another forum post)

Is there any way I could use the default launcher with a different search bar?

1 Like

No you can’t
Discussed already here more then once