Can not install instagram


I have a FP2 and I can not install INSTAGRAM. It will not be shown in the playstore. So I tried it via browser. I will find the comment: This App ist not compatible with your phone. As far as I can see, other users have installed Instagram. So what can be wrong?
Android 7.1.2
Build 19.02.1
Thank you for any help.

As far as I know, since the Android 7 upgrade some apps have become incompatible with the FP2. I don’t know when Fairphone is going to fix this however. I think there is nothing you can do at the moment.


Well … there’s still this Wiki and its “I regret upgrading, how do I downgrade?” section …

And there’s still LineageOS, just right now delivering Android 9 (LineageOS 16.0) to the Fairphone 2 …


Hmm, I find Instagram on Google Playstore and installing does work as well. I use FP OS 19.02.1. I didn’t try starting it - immediately removed again after installation :wink:

1 Like

I’m having the exact same problem with FP OS 19.05.3 and Android 7.1.2

It was working fine yesterday, but I just performed a factory reset last night and now it’s apparently incompatible. Did you manage to find a solution @staudenjunge ?

After the new FP OS version was installed, I tried to install Instagram again and it worked.

1 Like

This is a bug in the playstore (so it seems).
To fix this please follow these steps:

Go to Settings>Apps
Click on the three vertical dots in the upper right corner and select “show system”.
Open “Google play services>storage>Manage Space>Clear All Data”
Go back and repeat for “Google Play Services For Instant Apps” and also for “Google Play Store”.

Now you can open Google Play and install Instagram (and other apps that didn’t install).

Furthermore, please be aware you might have to setup some things again in the phone, like backup account. The phone should give a warning about this though.


Awesome, that worked for me, thanks so much!


you are welcome :smiley: :slight_smile:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.