Camera module just stop working

Hi guys,
I have a Fairphone 2 for which I upgraded the camera a few months ago, everything worked fine (as much as it can with a FP2… but let’s skip this for now) until last week when my camera module stopped working without any notice. I dont use it that often so I cannot tell any specific event that triggered this…
I have remounted it and nothing changes, it is not even detected (Setting -> About phone -> Camera module info = Unknown), the front module is still working
Anyone that can help?
I have the latest OS (Fairphone OS 18.04.1)

Hello Olivier,
did you try taking the FP2 apart and screwing it back on?

And cleaning the contacts?

1 Like

Maybe this will help you:

“At the two lower screw holes are small washers. These you can easily remove with a sharp object because they are only glued.”

That solved my camera problem.

Problem solved.

For the 2nd time I took the phone apart, removed the camera, carefully wiped it, screwed it back firmly and mounted the phone together. Not sure what exactly I did differently compared to the first time but I definitely did this more slowly and diligently.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.