Camera Error: Can’t connect to the camera

Tags: #<Tag:0x00007fefc92e2d48> #<Tag:0x00007fefc92e2bb8>


I have experienced the same issue with the new FP2 generation (bought June 2018).
The disassembling/reassembling “solved” the issue for my phone only for a couple of weeks, before I had the same issues (over) again.
Now I have found a “solution” that is stable for months which I would like to share here (maybe worth trying for some of you):

The main camera module is tightened by three screws: two screws at the electric contacts and one screw close to the camera lense. The latter (screw close to lense, see picture below) I did not tighten during reassembling - instead I kept it almost completely loosened (maybe you can also just remove that screw completely…).

This way I hoped that the electric contacts are more stable (without any forces bending the piece away from the contacts). For me, this works now reliably for months.

Hope this helps!



Hi there…i tried your suggestion a few times…but still no results…this fairphone 2 is only one month old…i am losing faith in this product already…any other ideas that might be helpful…
camera does not connect…please help…


#contactsupport ?


I had the same problem as you, I contacted the support and was sent a new camera module (free of charge, since my phone also was new) free of charge. I had to reinstall the new camera module one time but after that it has been working perfectly.


Hi again…I solved my problem. I did a reset and the camera now works but it still reboots immediately when I turn the phone off…


Sounds like one of the known bugs:


Just a li’l update:

Before emptying the cache it rarely worked. The hours after cleaning the cache it worked perfectly, then not at all. But these days it works often, and when it doesn’t I just shake it a little bit to… (paradoxically) “stabilize the image” and it mostly works now.

Which is, of course, nothing even remotely close to how it should be aka just working perfectly all the friggin’ time :stuck_out_tongue:

split this topic #48

A post was merged into an existing topic: No Connection from FP2 to PC


@mamue Your tip helped my colleague, simply bending the contact tongues worked perfectly for him. For myself it is not resolved yet, so I’ll try cleaning the contacts later on.

Thanks a million though.


OK, I’ve just tried your trick with the camera screws and I loosed off the top one. I’m a bit pessimistic though because it wasn’t tightly screwed in anyway and it is the two other screws at the bottom of the camera which seem important - they are either side of the contact plate underneath. I’ll report back when I’ve got something to say.


OK, I followed your advice @FairFlo and a month later I haven’t had a single recurrence of the issue. Hope it works for everyone else. You do need a tiny screwdriver though :smile:


This just happened to me, with an FP2 I’ve had for just 2 months. It happened a day or two ago then worked again - so does seem like a dodgy connection somewhere. Going to try the re-assembly and see if it goes away…