CalyxOS (is coming to) is here for FP4!

There are no visible changes:

2 and 3 are reverted in 4.1.9-2 to fix the issue when using a locked bootloader on some FP4.


Appart from THIS (Some FP4s fail to upgrade to 4.1.7 (#1214) · Issues · CalyxOS / calyxos · GitLab) everything is fine and stable so far :).

CalyxOS 4.2.3 with Android 13 has just been released as stable for the FP4! :star_struck: :raised_hands:

The update installed VERY smooth via the updater on my locked phone, it’s almost boring :grin:

Awesome job done by Calyx! :+1:


Noticed that as well - it was installed some minutes/hours ago. It was already downloaded and installed so it seems to be a full OTA (which is somehow understandable for a version change).

Can’t remember, that I ever jumped between (major) Android releases that quick - with one of my former phones. :star_struck: :raised_hands:

Will perform another full backup (and handle Magisk patch after OTA as always) before rebooting. Better be safe than sorry. ^^ (bootloader still unlocked here)

Done worked like charm. :partying_face:

Now at least the August Vendor and Firmware Patchlevel.

1 Like

That’s a typo on their website, latest CalyxOS release for FP4 is 4.2.2.

1 Like

CalyxOS for Fairphone 4 is out of the testing-only phase :partying_face: 4.2.5 beta is now available for easy install via the CalyxOS device flasher tool:

Love the pace of the Calyx devs!


I’m currently unable to install 4.2.5 via updater, it starts downloading (which seems too quick for a full OTA) and even starts installing (I see this via notification), but won’t finish. I tried switching between stable / beta channels and I’m also able to view the changelog from within the updater. @hirnsushi Have you sucessfully updated already? Any ideas how to debug this?


Are you using Magisk? :thinking:

Sounds exactly like what’s happening if you forget to restore the original boot.img before an update.

Edit: Followed the usual procedure and everything went fine :slightly_smiling_face:

Indeed I’m using Magisk and by surprise it shows as installed in Magisk-App, but I have an active install button instead of an uninstall button?

As far as I remember this was also the case for 4.1.9 to 4.2.2 update, which worked in that state… will add a screenshot later.

So that button …

… isn’t there? :thinking:

1 Like

Oh my god, I was in such a hurry, that I had the impression the install button in the upper right should be an uninstall button :joy:. Nevermind, it’s now installing after restoring original image… will report back, when it finished.

IT (JUST) WORKS! :slight_smile:

1 Like

just a quick heads up about device flasher: it seems it’s attempting to relock the bootloader after flashing, but only if get_unlock_ability returns 1.

cf. FP4: Don't lock bootloader if fastboot flashing get_unlock_ability returns 0 (21a1801f) · Commits · CalyxOS / device-flasher · GitLab

=> don’t use it if you’re not ok with this

see also Fairphone 4


You still have to confirm locking the bootloader with Vol. Up / Down + Power, so it’s not a completely automated process. If you don’t lock it, the system will boot up just fine as well.

I’ve tested the device-flasher several times with different options and so far haven’t been able to reproduce the dreaded get_unlock_ability=0. Locking and unlocking the bootloader works absolutely fine so far.

First time(s) locking my FP4, and it didn’t turn into a :brick: at any point, good times, still not keeping it that way :smirk:


Acording to CalyxOS there is an bug with Fairphone 4 bootloader so the CalyxOS developers can’t do more regarding locking the bootloader after flashing. So unless Fairphone fixed this bug then probably Fairphone 4 just won’t be able to be locked after flashing.
Which would be terrible if this isn’t fixed, becaus for many this unlocked bootloader was maybe the main selling point for buying a Fairphone 4.

There is a workaround, if you get hit by that bug.
But I’m not sure if it’s even necessary anymore. I had issues with that exact problem in the past, but I just flashed my phone again, get_unlock_ability set to 0 and at the point the device-flasher asks you to lock the bootloader, that flag was at 1 again. :man_shrugging:

Still plenty of ways to :brick: it through other means, but if you follow the device-flasher, I think you should be fine.

The people who’ve been running custom ROMs with a locked bootloader for months now might have a different opinion :smirk:

However they can still be hit by the issue as get unlock ability might still be 0…

If they already locked the bootloader (and didn’t brick), it doesn’t really matter if they got hit by that bug. Once the bootloader is locked, the OEM unlocking switch can just be toggled again.

CalyxOS for example, by default, automatically resets get_unlock_ability after the first successful boot, for security reasons. (That we already knew)
Whether that applies to booting an unlocked system as well, is something I’m trying to find out at the moment.

If that’s the case, it might explain some of the confusion around this issue. Maybe there weren’t so many people affected by the bootloader bug after all and some just experienced a feature :smirk:

1 Like

Dont think so in all cases

1 Like

Huh, that’s a curious case :thinking:
Not sure if there’s a misunderstandig at some point (or I don’t get it). The user started on a supposedly locked Calyx, but in the next post seems to be running DivestOS (how?), and ulimately fixed the problem using the Magisk method, which isn’t possible on a locked bootloader (and wouldn’t make sense, since you fake a locked bootloader with it).

The normal flow is, Calyx installed, bootloader locked, get_unlock_ability reset to 0.

To unlock the bootloader the switch in Developer Settings can just be set to on.
That’s what I’ve been doing all evening and so far the install process hasn’t failed me.

Now if you don’t lock the bootloader (going against the device-flasher instructions) and boot into the system, get_unlock_ability does get reset as well.
At that point, following the first run wizards suggestion to reboot the phone and lock it, does carry a risk.

I’ve asked the devs already, if that reset is a bug, or a side-effect of the feature mentioned above and if it’s the latter, whether they would consider removing that prompt and direct people to just using the device-flasher again.

Dont see that information :thinking:

I understood the toggle was set to off and greyed out and if this is the case, you cant enable,or?

Might be a curious case or many have this without knowing, because when the system runs smoothly and you would not want to flash something you wouldnt notice I guess…

The good thing is CalyxOS seem to have found a way to prevent issues