CalyxOS (is coming to) is here for FP4!

developer options:
switch on “Disable Bluetooth Hardware Offload”
Requests a reboot.
Works then.

1 Like

no, nothing
use their install script and run trough the process. But do exactly what you see in the concole window.

1 Like

seems to be the workaround for iodèOS, right?
According to the CalyxOS Testers Chat, this won’t work with the current build. But I will gladly test it myself once i flashed the phone.

1 Like

I tried to lock the bootloader again according to the instructions. After doing that it says that the device is corrupted and will not boot.
I can unlock the bootloader and install calyxos. Without relocking it will boot.

Is it a problem that the script cannot write critical partitions?

Have you done a factory reset after relocking? But in general, be careful with locking your bootloader while using a custom rom.

Regarding your warning… I changed the OS back stock and trapped myself in the fastboot loop :man_facepalming:

Yes, but the fix is expected for the next build (maybe mid of May).

I’m sorry for you and probably now it’s late. But for others passing by, if you want to be sure to avoid this, make sure OEM unlocking is enabled before locking the bootloader…


Version 3.5.0 is available now.

  • OTA update went fine
  • Bluetooth audio works out of the box
  • No problems with Magisk (new patched boot.img needed)
  • New material ringtones lack the basic Digital Phone one :roll_eyes: (so I uploaded it here)
  • Didn’t try a clean install yet

The script added:

fastboot flash frp frp.img
fastboot flash devinfo devinfo.img
fastboot --set-active=a

So basically the same change as in the latest FPOS factory images.


I can confirm that the OTA update process works. Bluetooth, however, is still not working for me. AAC and SBC.

Have you tried the workaround they provide here:

For most users BT audio will now work, however if BT audio still isn’t working for you, then:

  • Enable Developer Options
  • Turn on “Disable Bluetooth A2DP hardware offload”
  • Keep Developer Options enabled

ahhhh thank you !! I am an idiot. Works without any problem.


Yeah for some reason that was disabled for me already, probably because I played around with Bluetooth settings before, so for me it just worked™ :man_shrugging:

1 Like

That’s what they did as default setting in iode newest beta from yesterday as a workaround.

1 Like

I read your post when they figured it out, so I probably immediately tried it :smile:

1 Like

But it should not be the final solution, because of mor battery drain, because audio streaming is now done in CPU and not in HW. (I don’t notice any difference myself)

And, as I think, it’s not only a calyxOS or iodéOS issue. I think it’s maybe a driver issue in AOSP

where? in calyx?
as cde said in matrix, after I mentioned it there, calyx users shouldn’t do it, because it would not work…
But then, I saw in their gerrit, that they do it yourself just like that…strange :wink:

1 Like

Or even worse, a Qualcomm issue maybe, since Bluetooth is handled by proprietary blobs. Then we’ll probably have to wait much longer…

You mentioned it in the iode topic, but cde was also at least somewhat right, it didn’t work with the previous version, I think (now I’m not sure I really tried it :see_no_evil:)
Anyways, it’s working now :tada:

The “magic” of Open Source… :smirk:


ugh, I did an oopsie and tried to flash Calyx straight from /e/OS, and got stuck in a bootloop. the phone shows the splash screen, vibrates, and reboots again. you think flashing stock FP OS would make me get back on track? my bootloader is unlocked and I never tried relocking it.

If you didn’t lock your bootloader you should be fine, I’d just try installing CalyxOS again, they are using some of the partitions pulled from the factory images anyway.

Did you use fastboot flashing unlock_critical before starting the installation? :thinking:
It’s not mentioned in the how-to, but some of the partitions that are being flashed are of the critical variety :smirk:

Oh and just to be clear, there is an automatic reboot before the installation finishes, the boot, vendor, product and so on… partitions are flashed through the update mechanism in fastbootd / recovery (or at least it looks like that :man_shrugging:) are flashed separately (preceded by a reboot to fastboot again), maybe that’s what you have been seeing or where your issues start?


at first I didn’t notice that, and rebooted too quickly, but then I tried flashing again and that time I waited until the command finished doing it’s stuff. I’m still stuck in a bootloop.

fastboot flashing unlock_critical is apparently one of the commands in the Calyx’ script already (disregard, that’s the command I tried manually after reading your post, apparently I’m very easily confused):

fastboot flashing unlock_critical
FAILED (remote: '       Device already : unlocked!')
fastboot: error: Command failed

also, in the output I’m seeing several commands throwing “archive does not contain X” messages, like archive does not contain 'vbmeta_vendor.img'. I’m not sure if it’s a message because of some repurposed script, or am I missing some files, despite having verified the .zip file I downloaded from CalyxOS website.

edit: okay, I had to manually factory reset the phone (I thought the installer would take care of that?!) and it booted!

1 Like