CalyxOS (is coming to) is here for FP4!

Well, I’m still getting the link by modifying the URL with the current build number, that’s likely just the result of some CI pipeline.
But even if it isn’t, that’s not a problem, since FP haven’t released a new update since then, so there isn’t a risk of tripping Anti Rollback Protection anyway :man_shrugging:
I’ll check what’s happening on GitLab later :slightly_smiling_face:

I could install Magisk just fine, the installer for some reason didn’t even care about my modified boot.img (maybe this has been a full OTA :thinking:), so all I had to do was install Magisk to the other slot and reboot myself.

Edit: Just reread the release anouncement:

Factory images will be available at that time as well

So yeah, probably just not fed into the pipeline yet.

1 Like

I rebooted and now have lost root… will reflash the patched boot.img tomorrow, have no access to adb,/fastboot right now ;-). So there was no FP4-update for August yet?

Nope, but at least the rest is at the August level now:

Platform: 5 August 2022
Kernel: 5 August 2022
Vendor: 5 July 2022
Firmware: 5 July 2022

I’m hopeful for the September update to arrive earlier this time :crossed_fingers: :slightly_smiling_face:

We will also be releasing the September Security update next week with Android 12L for these devices

1 Like

@hirnsushi I tried to patch the boot.img from, which works (magisk showed no errors). But I can’t boot from that image anymore. I do get an error message" Cannot load Android system. Your data may be corrupt… etc.". If I chose “Try again” it’s booting, but not from the patched boot.img. Any ideas :-(?

Edit: Booting from an unpatched boot.img still works… weird.

Edit 2: Don’t ask me why, but at first I was patching a boot.img, which I had on my SDCard in the FP4 (which is exFAT). I then tried it from the internal storage (as magisk also writes the patched boot.img into the Download folder) and used that patched boot.img… and it works. WHAT is that?

As I’ve mentioned above… are the new factory images by name only, there’s still the previous release inside. So you are patching a 3.7.2 image and try to run it on a 3.8.0 system, which will throw some errors, but still should be fastboot bootable to install Magisk afterwards.
I’ve uploaded a boot.img that’s been pulled straight from a running 3.8.0 system, patched with Magisk, for exactly that reason :point_down:

Maybe pull both boot.imgs to your PC and compare their hashes :thinking:
If it works, it works though :smirk:

1 Like

Hi all,
I have received a FP4 and would like to install Calyx directly. I have two questions before I begin:

  1. Reading in @hirnsushi’s comment that the September update may come soon, I was thinking that it may be better to wait for it, as I’m in no hurry. What do you think?

  2. What’s the situation with the lock the bootloader issue? I have read the threads about Calyx on the forum, as well as the Trapped in fastboot one and it seems that some people managed to relock the bootloader while others bricked the phone, both in August. Should I leave it unlocked just to be sure, or should I try to lock it if fastboot flashing get_unlock_ability is set to 1. As you would guess, I don’t want to brick the phone and I was getting cold feet reading all the stories about bricked phone after a Calyx, iodé or /e/ install, but it would feel weird to use Fairphone OS after 6 years on Lineage or FPopenOS on my FP2…

  1. I would wait for 3.8.0 to be released as stable / factory images, which should happen any minute now. OTA updates have been completely flawless so far, so once the September update becomes available you can just upgrade.
  2. The two most important things to look out for is, as you said, checking get_unlock_ability and making sure you don’t install a ROM that has a patch level older then the one you were running before.
    I still wouldn’t recommend it, there’s still some risk involved, but if you do lock your bootloader, make sure you meet both requirements.

Thanks for the fast answer! I will not lock it then.

Good recommendation not to lock. Question: If I would lock any time later- what would happen? Are data deleted again? Hope not!

Yes, every time you lock / unlock the bootloader or the critical partitions, userdata gets wiped.


Just updated to CalyxOS 3.8.0 (from 3.7.2, locked bootloader, no root) without issues :raised_hands:

Love the option to disable constant fingerprint unlocking.

Settings: Allow user configurable fingerprint wake-and-unlock (for FP4)

My Phone would regularly unlock in my pockets (because I usually keep my hand there as well). Now I have the same behavior as under FPOS :ok_hand:

I love what Calyx has been doing for the FP4 so far! :star_struck:


So is it recommended to go for an OTA Update right now?

I did not yet get any notification about an update :face_with_monocle:. Maybe I disabled some setting but not sure what I configured differently. Maybe Afwall+ blocks something. At least “CalyxOS Update Client” is allowed to access the internet.

Also is there anything I need to prepare in regards of Magisk (install a new 3.8.0 patched boot.img ) or is the OTA way of upgrading still the same?

Are you on the stable release channel? :thinking:
It’s still in beta, and there were some potential bugs discovered, that might have moved the timeline a little.

Magisk reinstall should be business as usual :slightly_smiling_face:

You are right, I’m on stable channel. :man_facepalming:
Will change that and see what happens.

So do I have to pass a new patched boot image on step 3 or will Magisk just be installed (re-installed) by/via the Magisk app?

Nope, you don’t need to supply a boot.img, the Magisk app just patches the other slot (if you don’t reboot your system in between and loose root).

Ok, now (yesterday) 3.8.0 was marked as stable and the related issue was closed.

So my phone (still configured to stable channel) started downloading:

It is possible to show the Changelog by clicking on the Downloading notification

My system update settings are:

This morning it looks like this:

So it already installed the new version. Is this a problem, when the order is not 100% the same?
I mean you ( @hirnsushi ) described that Magisk should be uninstalled beforehand.

Or can I still do it now (still before reboot) and directly reinstall it to Inactive Slot?

Also is there a way to control this a bit more? Like download but not directly install?

My phone did the same thing:

If you want to controll it, try turning off Automatic System Updates in Developer Settings. We’ll have to wait for the next one to see if that actually works :man_shrugging:

1 Like

Preparing another “full” backup according my “backup strategy” ^^ right now and will give it a try then.

Will report back the result.

Hi guys,
After my initial attempt (which resulted in a locked bootloader) I want to give it another shot.
I couldn’t find calyxos 3.8.0 for Fairphone. Do I need to install an older version and the latest update is OTA?
My security update is still July, should not be s problem.

Thanks in advance!

I also requested such an option in their GitLab: OTA update behaviour should be configurable (allow to disable / delay auto-updates) (#1161) · Issues · CalyxOS / calyxos · GitLab