CalyxOS (is coming to) is here for FP4!

While the double power to open camera works out-of-the-box on stock OS, a long press just open a menu with emergency/shut down/reboot.

Did you configure something for the flashlight, or is it Calyx specific?

I don’t think that’s available in stock FPOS, in Calyx you can turn it on under Settings → System → Buttons and it only works when the screen is off.


also works with Iode (on the FP3), its long press on lockscreen, so when its not active for power menu. I think it was also available on the FP2 with LOS, so maybe another LOS function.


Another little question. (I’m not sure if it is Calyx or Android 12 related)

I normally use the Calendar app “Etar” (git) and as I don’t want to get notifications/reminders twice I disabled the standard Calendar app.

I was able to include all my calendars after I set up CalyxOS.

The only problem is that it does not send any notification (not for appointment nor for Birthdays - I use Birthday Adapter in addition to put the birthdays out of the contacts into the calendar).

As I don’t want to miss anything I now enabled the standard Calendar again and it sents out the notification. Not sure what is the problem with Etar. Any thoughts?

EDIT: While I was looking about a way of installing system apps and where, I checked the folders /system ,/system_ext and /product I saw that there is a “Etar” under /product/app
Checking the Calendar App Info I see that Calyx already ported Etar as there default calendar (package name org.calyxos.etar). So actually no need to install Etar manually (was also confused why it look so familiar to me ^^).

:white_check_mark: → Etar uninstalled, problem solved. Probably two “Etars” on the same OS are not a good idea.

I’m interested to give CalyxOS a try, but what I didn’t manage to find out is where are the official installations instructions for FP4? Install CalyxOS doesn’t list it and I have no idea where beta versions are offered.


The instructions are listed here, not very easy to discover, I know :see_no_evil:
You can get the latest beta here:

I wouldn’t recommend locking the bootloader at this point, still too dangerous.
At the very least check that fastboot flashing get_unlock_ability doesn’t return 0, but generally just keep it open for now.


Wow, thanks… really hard to find ;). As Bootloader Unlocking Code for Fairphone 3 - Fairphone is unreachable because of maintanance, I’ll try tomorrow :).

Is THIS also relevant for CalyxOS?

The FP4 comes with an anti-rollback feature. Google Android anti-roll back feature is supposedly a way to ensure you are running the latest software version, including the latest security patches.

If you try installing a version of /e/OS based on a previous AOSP core version than the one running on your phone, or based on a security patch that is older than the one on your device, you will brick your device.

To check the security patch level on your phone with a locked bootloader, prior to installing /e/OS, open your phone Settings » About Phone » Android Version » Android Security Patch Level.Then compare it against the level of the security patch on the /e/OS build as visible in the Downloads for the FP4 section below.

AFAIK my FP4 is currently on Android-Patchlevel from 05. July 2022 and the only offered CalyxOS files I found ( seem to be from May 2022 (May 2022 Security update - Fairphone 4, OnePlus 8T, 9, 9 Pro).

Help wanted, before I get a working USB-C data cable and brick my FP4 :-D.

I’ve asked the devs already if that is relevant to CalyxOS as well, so far there hasn’t been any movement on that issue (DEF CON ended just a few days ago, people need a brake sometimes :slightly_smiling_face:).
My guess would be, yes, definitely.

The 3.7.2 beta I linked is at patch-level 05. July 2022 as well, so you would be safe on that front, but I would still consider leaving the bootloader unlocked.
I can’t repeat this enough, whatever you do, check fastboot flashing get_unlock_ability!


I read in the other CalyxOS thread, that Magisk (which I need) requires unlocked bootloader, so yes I will leave it open once I can get onto the installation :). Thanks!

1 Like

I was at that point as well and basically followed @R2D2 's steps here. As I also wanted to add Magisk, so I created my own notes, which are mostly similar and only a bit different at the Magisk part. So I did not post it again and just confirmed that it worked. (maybe helpful for others when we add another wiki post like “Howto install Calyx OS with Magisk on FP4” or so)

Or you just combine the infos of:

like I did. :wink:

(and I didn’t though about the patch-level thing, but I directly flashed Calyx after my FP4 was delivered)

1 Like

That “The bootloader is unlocked” message during the start of the phone is really annpyong :-1: .

1 Like

So I flashed CalyxOS, had to upgrade the fastboot executable on my box in order to get the working ;). During the first boot the OS warned me that I should relock my bootloader, which I did not.

First impressions in comparison to LOS, it’s looking ugly and I have to get comfortable with that default design and launcher. I’m already missing the extended reboot-menu and the screenshot option in the Power-button-press-menu. The preinstalled apps selection is great! I’m still in the process setting options as I had them on my beloved FP2 with LOS 18.1.

Can I move my FP2 seedvault backup to the CalyxOS FP4? I even don’t want to lose my own dictionary, which has gotten SO many words over the last years ^^.

Currently there is no newer version available even when switching to beta.

I’ll keep you updated… Thanks for all your help.

That’s Android 12 for you :smile: takes some time to get used to coming from a Android 11 ROM.
I actually kind of like it, set the background to that gray Calyx :zap: and it will get a lot less colorful.
Haven’t found an option to enable the extended boot menu though.

I mean, Seedvault started in CalyxOS originally, should be pretty standard, so it’s definitely worth a try :crossed_fingers:

There is an issue in Etar regarding notifications:

CalyxOS has fixed this in it’s default calendar (which is based on Etar) already:


I know that option from LOS (which was the OS I used on my FP2 as well), but I never used the screenshot option in the power menu. Why not taking a screenshot pressing Volume Down + Power ?

Or if you configured the 3 button navigation on the bottom of the screen → open the running tasks with the square button on the right (or however the open task can be accessed):

1 Like

I found gapps for Android 12L here (found it via articles about flashing LOS) and the swipe lib seems to have a new place in Android 12 (L? - I assume it is the same for 12). → /system/product/lib
Also it seem to be the same file since 2008 ^^ (I compared it to the one I still have from Android 11 and used with my FP2).

So as soon as I will get used to creating Magisk modules I will create my own one about this as well.

EDIT: Before doing this I though, that it might be an option to report this to the existing Module devs: GitHub - NullCode1337/GlideLib: Install the libraries required for Glide Typing, systemlessly but the issue section seems to be disabled there, so I don’t know how. :thinking:

I used the arm64 version of the module as the FP4 has an arm64 architecture. On the other hand the lib in the gapps package is located under a normal lib folder ( /system/lib/ or /system/product/lib/ is probably not that important → not lib64 like the module puts it)

## on my FP4 (after enabling the GlideLib module):
adb shell su -c ls -l /system/lib64 | grep libjni
-rw-r--r-- 1 root root  1112352 2022-08-10 23:05
-rw-r--r-- 1 root root    24024 2009-01-01 01:00

Great, that is sufficient for me :).

Is there a way to change the Android 12 accent color within CalyxOS? I’m missing the setting “Colour palette” in Background & Style setting :-(.

Sadly that feature isn’t in AOSP and I haven’t heard of an open reimplementation ready to replace it (but haven’t looked in a while).

There is a live wallpaper based workaround called LWP+, but that isn’t open source and apparently also contains ads, so I haven’t tried it.

Edit: Well, there is the Android 12 Extensions Magisk module, but it seems abandoned and apparently doesn’t fully work on 12L. Calyx devs already said they won’t include it in its current form, which isn’t surprising since they try to stay as close to upstream as possible.
I guess we’ll have to wait for this to get implemented in AOSP or Lineage. GrapheneOS apparently have a similar feature, but nobody is going to touch that code, especially not to pull it into CalyxOS.