CalyxOS (is coming to) is here for FP4!

You might ask a #fairphoneangel to assist you with flashing, if there’s one near you…

I wonder if or when updates for CalyxOS for FP4 are/will be available, On their website more than a month ago they said "next week. I’m a bit unsure - is that update still out and my FP4 did not get it? I recently installed netguard in whitelist mode - but I think this should not be a problem, because systemupdate is whitelisted.

Looks like a misplaced query, isn’t this better directed to Calyx ??

Just moved your question to this general Calyx topic, maybe someone has some insights


Isn’t this a user community here? I know there are some people using CalyxOS here - is it really “misplaced” to ask other users if they know something? What else is this forum for? I tried to find some infos in the CalyxOS Matrix channel - but I did not get along with this - one big thread for everything? Did not find any information on updates for FP4.

“Better directed to Calyx”? Do you really think it makes sense that every user directs questions like this to the developer? I think they have better things to do.

I won’t complain if nobody answers my question here, but I don’t like the “misplaced” answer. :roll_eyes:


What version have you installed? I think latest beta release is


As @yvmuell already said, 3.7.2 is still in beta at the moment.

From what I can tell from their Matrix channel (yeah I hate the one-threaded-ness too), the team has been doing crunch time to get the first release for the Pixel 6a out, that’s probably why it hasn’t been moved to stable yet.
I’ve been using it for quite some time now without problems, you can safely switch to that beta if you want to.

Just go to Settings → System → System update settings → Release channel and change that to Beta :slightly_smiling_face:

1 Like

Thanks! I did not know there are two update channels, stable and beta. My notion was that CalyxOS for FP4 in general is considered beta. It works fine for me - I am only concerned about security updates.

OK, now I know why it’s still beta. The update broke NetGuard - says it can’t load the VPN service and it’s probably a bug in Android. Hope it it will be fixed with the stable version soon…

I’m sorry, I don’t use NetGuard so I haven’t noticed :see_no_evil:

Strange, my tailscale (headscale) VPN over WireGuard still works fine, I wonder what could be the issue here.

I assume you are referring to the NetGuard FAQ here, right?

(35) Why does the VPN not start?
NetGuard “asks” Android to start the local VPN service, but some Android versions contain a bug which prevents the VPN from starting (automatically). Sometimes this is caused by updating NetGuard. Unfortunately this cannot be fixed by NetGuard. You can try to restart your device and/or revoke the VPN permissions from NetGuard using the Android settings. Sometimes it helps to uninstall and install NetGuard again (be sure to export your settings first!).

Have you tried reinstalling it? Does the problem persist?
Could you check if you have another VPN service enabled under Settings → Network and Internet → VPN :pray:

I wouldn’t count on that issue getting fixed when it moves to stable, as far as I can tell from the issue tracker this problem hasn’t been reported, so it’s unlikely someone is working on it.
If you can’t get NetGuard to work, consider opening an issue so the devs are aware of the problem.

1 Like

Of course it’s not your fault - I was perfectly aware that this is beta and that there is a risk.

No, I was not refering to the FAQ, but to a message on the notification screen of the phone. I’ll try reinstalling NetGuard tomorrow - thanks for the hint.

It worked! After uninstalling/installing NetGuard it works again. Thank you for pointing me to the FAQ.


I run the latest CalyxOS (without Gapps/microg; rooted via Magisk) since end of July and I’m more ore less fine with it. It is quite stable even still not official yet.

I have a couple of potentially beginners questions and some of them were already asked in the Calyx Matrix chat, but nobody reacted, so I give it another try here. Whoever have a suggestion, just reference the question number and answer ;-). We can also open another “Configuration Q&A CalyxOS - FP4 - Thread” if this is not he right place to asked these questions.

  1. Is there any documentation about the repos: “The Calyx Institute” and “CalyxOS Local Repo”? What are they used for? (they are both enabled in the pre-installed F-Droid → especially the local one confuses me)
  2. Is there a simple way to install a working Gcam (or a Port) on a Fairphone 4 with Calyx (Note: no GApps nor microg should not be installed → we discuss this already here and below)?
  3. Can I put shortcuts on the lockscreen? If yes, how? (e.g like a Camera App - I remember this from LineageOS I used on the FP2 before)
  4. I like to swype/glide type. There are OpenSource Keyboards which are on a good way (FlorisBoard, OpenBoard, AnySoftKeyboard) but still most of them are not fully functional in this special regards. So I always copied the under Android 10 and 11 (to /system/lib) and after a reboot you can enable this functionality for ASOP keyboard. The problem now is, that I don’t find arm64 Android 12 Gapps to download, which consist of this library → . Is there anyone who successfully enabled it - if yes how?
  5. The Fairphone 4 does not have a notification LED, so I was wondering if there is a simple way to indicate, that there is a new notification (mostly interested about messages) when the screen is off? (e.g. blinking, glowing, would be already enough for me … back in the days there were apps like ACDisplay. Right now I use the app AlwaysOn but it is not updated since 2020 + not 100% satisfying (some apps are not discovered correctly etc.) I also know this thread, but nothing convinced me up to now. :man_shrugging:
  6. How about Magisk Updates. Is there anything which have to be kept in mind? We discussed Calyx OTA upates here: Howto install Calyx OS on FP4 - #15 by Smojo (which considers uninstall Magisk before etc. …), but how about an Magisk update itself? Just apply via Magisk App? Reflash the new version via fastboot? How big is the risk to do something wrong and potentially the OS will not start anymore.
  1. The Calyx Repo includes apps they ship themselves, like the modified AuroraServices, or the GCamPhotosPreview they created. .apks are here, the repo is here. The local repo is there for offline install during first boot, similar to how you can install bundled software from a Linux installation medium.
  2. Well, let’s see how that other discussion turns out :smirk:
  3. By default, no.
  4. You shouldn’t modify anything under /system if you don’t absolutely have to, try this GlideLib Magisk module. Haven’t tested it, I don’t use swipe / glide, so as always YMMV :man_shrugging:
  5. I use FlashAlert for the few times I need that
  6. No special process needed, just push the update button in Magisk and reboot.

Thanks again for your answers, @hirnsushi .

about 1.
so basically after the first boot the local repo is not needed anymore? I just like this Store Client more than the official F-Droid one.
Neo Store | F-Droid - Free and Open Source Android App Repository
and I wanted to understand if the local repo is important.

about 3.
So does anyone have an alternative for a quick Camera access when the device is locked?

about 4.
I tried the module, but “Gesture typing” didn’t show up in the menu after reboot. :-/
Normally it should be here: Settings > System > Languages & input > Virtual Keyboard > Android Keyboard (AOSP) > Gesture Typing (… > Enable gesture typing) :man_shrugging:

about 5.
I tried FlashAlert as well, but it is way to bright imho. Let’s see how I will workaround this. I can also wear my smartwatch all the time and if not I have to live with the fact that I need to turn on my phone to check.

Does this (press power twice) not exist in Calyx?


Not really, if I compare my installed K9-Mail with the one available from the local repo, it’s several versions behind, makes sense since it got shipped with the ROM. Everything you can get from the local repo you should be able to download from either the Calyx repo or the standard F-Droid repo.

I use “press power twice”, like @yvmuell suggested, as well. Works great :slightly_smiling_face:

1 Like

Ok will try to use it. I already use long press for flashlight. So I just have to get used to the double press functionality. Thanks for the hint. ( Both of you :wink: )

While the double power to open camera works out-of-the-box on stock OS, a long press just open a menu with emergency/shut down/reboot.

Did you configure something for the flashlight, or is it Calyx specific?

I don’t think that’s available in stock FPOS, in Calyx you can turn it on under Settings → System → Buttons and it only works when the screen is off.