CalyxOS (is coming to) is here for FP4!

3.5.1 with May 5 security updates here (I got an OTA at least once since installing)

I’m now on CalyxOs. How do I go back to Fairphone stock OS withour bricking it after locking the phone?

Just follow the official procedure and you should be fine :wink:

Avoid relocking bootloader at all cost.

Edit: also, if after the procedure you end up stuck on logo/bootlooping go back to fastboot mode and run:

fastboot --set-active=a

If that doesn’t work, go for b :wink:

1 Like

I can go back but I shouldn’t relock?


There are currently a lot of cases of fp4 getting bricked after relocking the bootloader to the point that only customer support can fix it.

1 Like

My advice is this one

1 Like

I would like to give CalyxOS a try, but it seems like I’m blind… Cannot find the script for the FP4 (only for the official pixel devices). Could someone point me to the script?
I don’t know why, but there site is quite confusing to me…

Just realized that the factory-image is not the original FP image, but CalyxOS with all scripts inside… :man_facepalming:

I know that it is possible after having used Custom Rom to go back to FPOS and to lock bootloader.
Now my question: Is it possible at a later stage to unlock the bootloader again and to flash again any Custom Rom? Or is the number of unlocking limited?

I’ve never read or heard that it’s limited and I also can’t imagine that.
Please be aware, that when going back to FPOS the function OEM unlock may be disabled by default. So in case something goes wrong on relocking the device, you might hard brick your FP4.

1 Like

You can do it as often as you want

1 Like

Okay and thanks. My problem was that I unlocked without any problem and also unlocked critical. But it was not possible to flash Calyx. Fairphone original software remained unchanged. Tried many different cables and latest ADB and Fastboot software and also under Linux and Win 10. After 2 days of searching a solution my nerves were at the end :wink: and I locked again and also locked critical. I am sure that it is locked because the 2 days in unlocked condition I received after every reboot the info that Fairphone must be locked and how unsafe it is with unlocked bootloader. Also the toggle in Developer Options is back again!

You might ask a #fairphoneangel to assist you with flashing, if there’s one near you…

I wonder if or when updates for CalyxOS for FP4 are/will be available, On their website more than a month ago they said "next week. I’m a bit unsure - is that update still out and my FP4 did not get it? I recently installed netguard in whitelist mode - but I think this should not be a problem, because systemupdate is whitelisted.

Looks like a misplaced query, isn’t this better directed to Calyx ??

Just moved your question to this general Calyx topic, maybe someone has some insights


Isn’t this a user community here? I know there are some people using CalyxOS here - is it really “misplaced” to ask other users if they know something? What else is this forum for? I tried to find some infos in the CalyxOS Matrix channel - but I did not get along with this - one big thread for everything? Did not find any information on updates for FP4.

“Better directed to Calyx”? Do you really think it makes sense that every user directs questions like this to the developer? I think they have better things to do.

I won’t complain if nobody answers my question here, but I don’t like the “misplaced” answer. :roll_eyes:


What version have you installed? I think latest beta release is


As @yvmuell already said, 3.7.2 is still in beta at the moment.

From what I can tell from their Matrix channel (yeah I hate the one-threaded-ness too), the team has been doing crunch time to get the first release for the Pixel 6a out, that’s probably why it hasn’t been moved to stable yet.
I’ve been using it for quite some time now without problems, you can safely switch to that beta if you want to.

Just go to Settings → System → System update settings → Release channel and change that to Beta :slightly_smiling_face:

1 Like

Thanks! I did not know there are two update channels, stable and beta. My notion was that CalyxOS for FP4 in general is considered beta. It works fine for me - I am only concerned about security updates.

OK, now I know why it’s still beta. The update broke NetGuard - says it can’t load the VPN service and it’s probably a bug in Android. Hope it it will be fixed with the stable version soon…