Buttons pressed randomly

Make a screenshot of your touchscreen test results and send it to Support. You’ll probably get a new screen on warranty.

My phone goes a bit crazy quite regularly, it starts typing by itself (a text, tweet or fb message depending on what I’m using), opens other apps and won’t let me power off which is the only thing I can do to stop it. It has also gone to call people randomly. Any idea why this is happening?
I had an S2 before this, by holding down the on/off button the phone would shut down after a few seconds, this may be a good feature to add to the next version, rather than having to press “Power Off” then “yes” in case of emergencies or meltdowns.

@Lindad you should try and perform the Touchscreen Test and send the results to support.

Also check whether your battery might be starting to bloat, as this can cause all sorts of problems.


I did the touchscreen test, the phone did what it was supposed to and the battery is not bloating…could it be something else?

Hi Sarah_HH and others. Don’t know if i am the only Dutchie in this thread but i have the same issue. My phone also shows other ghost-actions but they all could relate to a lost connection: Airplane mode suddenly enabled, automatic date-time settings disabled, bluetooth enabled, but also more weird things like randomly typed sms message…
Yesterday, i was at a large event with 600.000 visitors and a temporary phone network installed. And exactly there, the behavior of the phone was much worse than i ever noticed before. I can imagine that it was related to my sim trying to switch between various networks. I use Tele2 which doesn’t have its own network and is always roaming.
At the same event, i met a stand of FP and asked one of the tech guys about the problem. He didn’t recognize it and just advised a factory-reset. Will try…

Your symptoms to me sound like a hardware failure. (I’m baffled that they could not tell you that at the FP stand… :stuck_out_tongue: ) Please do the Touchscreen Test.

Hi Stefan, thanks for your reply.
Maybe the man at the stand was so sure that this could not be the SIM issue, that he didn’t mention it. But i also read somewhere that an old sim card could cause ghost-actions as well.
I did the screen test, everything seemed to be ok. I’ve never seen any ghost touches really happening, only found the phone in a strange state after i unlocked the screen.
Did the factory reset and updated kola nut, will install some apps again and see what happens.


@Lindad (sorry for the late answer) @JanRap as far as I know Ghost touches are either caused by a malfunctioning screen or by static (Usb-cable, friction in the pocket while moving, faulty Sim card?, … )

Try to find out in which situations the ghost touches happen and then prevent the static by replacing the usb cable, using a (different) sleeve for the Fairphone while it’s in your pocket or whatever…

1 Like

Thanks Paul, it usually happens if I’m reading articles online and maybe using more than one app at a time (switching from Twitter to firefox for example). I don’t have a cover on the phone and don’t carry it on my person. It hasn’t happened though since I first e-mailed you, kinda typical…


Last night my phone developed the same problem, when I plugged it in to charge - but it persisted after removing it from the charger. I tried rebooting to factory mode to do the tests, but the random selecting of buttons was continuing during the factory reboot, so I couldn’t even get to the point of “item test”. Additionally, I can’t even use the power button to turn the phone off or reboot it when on - I have to remove the battery. When on, it doesn’t respond to touches at all and is entirely unusable.

I’m really frustrated, since I need my phone, and am a bit disappointed that this issue seems to be a relatively common problem. Does anyone know of any other things to check for?

I’ve sent a message to the support team too, though not sure how long it will take for a reply given that it’s the weekend.

my touch screen sometimes act really weird- i try to open an app, and a different app is opens…
things like that. i suspect that the glass screen protector is the cause, but sometimes if i restart the ff
the problem is fixed for a while.
what should i do?

You should perform the touchscreen test to find out if its a hardware issue.

1 Like

FWIW, my 2 cts about the charger and random touch problem in case you really need to charge and text at the same time:

  • The problem only occurs with some sockets in my house, so perhaps try another.
  • Sometimes the problem goes away when rotating the charger in the socket, switch the polarity so to say.

I was unaware that there exist grounded chargers, I’ll keep that in mind, thanks.

I was watching a Youtube clip todayon my FP1U (not touching phone, all working fine no damage or incidents). The phone started behaving as if screen were being swiped / buttons pushed. Turned off and on again several times - now the screen will not move past the security swipe code page. It does not recongnise my touch and responds as if someone is trying to enter the wrong security swipe.

I’ve tried removing battery and SIM - no response. I now also see a warning logo in the top left corner. Do I need a repair job? Anyone had similar experience? Very frustrating!

You should perform a touchscreen test.

Thanks Paul I have done this test. The phone responds very slowly to touch - it generally registers touches in red squares at the edges but not reliably in the centre. Lots of ‘imaginary’ touches picked up and my single touches not picked up. If screen is like this I imagine I need repair? Could it be a software problem?

A positive touchscreen test indicates a hardware problem. Take a screenshot of the test and send it to support. If you didn’t break the screen yourself and you still have warranty they’ll probably replace it for free.


Ok thanks have done this. FYI screen test detected same pattern of picking up a ‘fake’ vertical swipe on left hand side as happens when phone in normal mode.

So I tried the test, and even getting to the test was a problem. I could only move throught the menu with volume down? Nope, my phone could get everywhere without me doing anything. When I managed to open and perform the test, the red squares in the right down corner got green within 2 seconds, again, without me doing a thing. The screen responds to my touchs, but also to non-existing touchs.

Btw, my phone is not charging, I am holding it like I always do… I have it 1,5 years now.

I’ll also write to support.

It’s normal that you can only navigate with volume down in testing mode.
The result of your test suggests that it’s a hardware malfunction and since you have your FP for less than two years you’ll probably get a replacement screen on warranty. :slight_smile: