Buttons pressed randomly

I have the same issue, screen is going crazy. I have tried the screen test twice and seemed to go ok, but the problem persists.
I am contacting support rigth away as it seems to be the only option.
Thanks anywasy for the inputs but it seems a rather broad problem - thinking about replacing it.

I did contact Support. By on my part insisting that the problem persisted through all the tests, resets and downgrading of OS that Support suggested, I finally got them to conclude, that it is a hardware malfunctioning. They send me a form to fill out as I could submit the phone for repair. It should be covered by warranty, but first I have to pay for the carrier, I guess, and then they will determine whether the problem is hardware related or not. But I rest assured that it is and I will send the phone when I get around to it.

1 Like

Just for the record, I learned that if they repair your FP it on warranty, you should be able to apply for a carrier expenses refund. (Which I did not. But the 10.10€ were a good investment, in any case.)

1 Like

Sorry for reopening this thread but I found that when the problem appears I simply lock the screen and unlock it and everything works normally.
I must admit after 1.8 upgrading the problem appears rarely but it does, while with 1.6 it was more frequent; in both case locking the screen seems to reset the situation.
Bye! :smile:

P.S. my problem does not depend on charger connected nor handling the phone without touching the back metal cover.

All of sudden my phone has gone possesed. The touchscreen seems to have a life of its own. it is as if someone was tapping randomly and superfast. Doesn’t respond to any of my tapping. This happened literally overnight, with no apparent reason. it was switched off and when I turned it on it started happening, no previous signs of malfunctioning. It never fell, didn’t seem to have got wet, was in my bag in its protective case. Any help appreciated.

I moved your post here as it appears to be the same problem.
Please do the touchscreen test and if the result is abnormal contact support and show them a screenshot.

In the last few weeks my Fairphone seems to have taken on a mind of its own.

I can set it down on the table, not touching it at all, and it starts rotating between screens, starting the timer, setting off alarms…

This doesn’t happen all the time but I notice it maybe once every two days or so. Any ideas?

Please look at the posts above. Especially I advice you to do the touchscreen test.

Did the touchscreen test and it seems fine. I haven’t seen the problem since installing the latest update so will see if it persists.

1 Like

Hi, i had the same problem when charging my phone. Now it is permanent issue, do you have any advice?
I run the phone and test the touchsreen. It appears that the phone detects inputs in the bottom left part of the screen severals times per second.

Make a screenshot of your touchscreen test results and send it to Support. You’ll probably get a new screen on warranty.

My phone goes a bit crazy quite regularly, it starts typing by itself (a text, tweet or fb message depending on what I’m using), opens other apps and won’t let me power off which is the only thing I can do to stop it. It has also gone to call people randomly. Any idea why this is happening?
I had an S2 before this, by holding down the on/off button the phone would shut down after a few seconds, this may be a good feature to add to the next version, rather than having to press “Power Off” then “yes” in case of emergencies or meltdowns.

@Lindad you should try and perform the Touchscreen Test and send the results to support.

Also check whether your battery might be starting to bloat, as this can cause all sorts of problems.


I did the touchscreen test, the phone did what it was supposed to and the battery is not bloating…could it be something else?

Hi Sarah_HH and others. Don’t know if i am the only Dutchie in this thread but i have the same issue. My phone also shows other ghost-actions but they all could relate to a lost connection: Airplane mode suddenly enabled, automatic date-time settings disabled, bluetooth enabled, but also more weird things like randomly typed sms message…
Yesterday, i was at a large event with 600.000 visitors and a temporary phone network installed. And exactly there, the behavior of the phone was much worse than i ever noticed before. I can imagine that it was related to my sim trying to switch between various networks. I use Tele2 which doesn’t have its own network and is always roaming.
At the same event, i met a stand of FP and asked one of the tech guys about the problem. He didn’t recognize it and just advised a factory-reset. Will try…

Your symptoms to me sound like a hardware failure. (I’m baffled that they could not tell you that at the FP stand… :stuck_out_tongue: ) Please do the Touchscreen Test.

Hi Stefan, thanks for your reply.
Maybe the man at the stand was so sure that this could not be the SIM issue, that he didn’t mention it. But i also read somewhere that an old sim card could cause ghost-actions as well.
I did the screen test, everything seemed to be ok. I’ve never seen any ghost touches really happening, only found the phone in a strange state after i unlocked the screen.
Did the factory reset and updated kola nut, will install some apps again and see what happens.


@Lindad (sorry for the late answer) @JanRap as far as I know Ghost touches are either caused by a malfunctioning screen or by static (Usb-cable, friction in the pocket while moving, faulty Sim card?, … )

Try to find out in which situations the ghost touches happen and then prevent the static by replacing the usb cable, using a (different) sleeve for the Fairphone while it’s in your pocket or whatever…

1 Like

Thanks Paul, it usually happens if I’m reading articles online and maybe using more than one app at a time (switching from Twitter to firefox for example). I don’t have a cover on the phone and don’t carry it on my person. It hasn’t happened though since I first e-mailed you, kinda typical…


Last night my phone developed the same problem, when I plugged it in to charge - but it persisted after removing it from the charger. I tried rebooting to factory mode to do the tests, but the random selecting of buttons was continuing during the factory reboot, so I couldn’t even get to the point of “item test”. Additionally, I can’t even use the power button to turn the phone off or reboot it when on - I have to remove the battery. When on, it doesn’t respond to touches at all and is entirely unusable.

I’m really frustrated, since I need my phone, and am a bit disappointed that this issue seems to be a relatively common problem. Does anyone know of any other things to check for?

I’ve sent a message to the support team too, though not sure how long it will take for a reply given that it’s the weekend.