Build FP2 in debug mode

Hello everyone,
I followed the procedure to build FP OS in release mode and everything worked. I tried to do the same for debug mode (choosecombo 2 1 3) and the following error ocured :

make: *** No rule to make target 'out/debug/target/product/FP2/obj/SHARED_LIBRARIES/libwpa_client_intermediates/export_includes', needed by 'out/debug/target/product/FP2/obj/SHARED_LIBRARIES/libhardware_legacy_intermediates/import_includes'. Arrêt.

#### make failed to build some targets (03:09 (mm:ss)) ####

Does someone has already solved this problem?

Thanks in advance =)


It seems the binary blobs are missing. Did you download and extract the blobs?

If so, can remove the out directory and try again?

. ./build/    # here the blobs get copied in the out directory
choosecombo 1 FP2 2

Thank you for your answer, but your choosecombo command is for release build.

I precisely followed the procedure and used the command
choosecombo debug FP2 eng
instead of
choosecombo release FP2 user

I still have the same error.
Is there a trick to do to be able to build in debug mode ?

My bad. I missed that part, that everything worked for release builds. As for now you won’t be able (at least it is not supported) to make debug builds with the sources/blobs we published. Sorry for that.